Bug 123616 - tmscsim SCSI driver not included
tmscsim SCSI driver not included
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
: FutureFeature
: 124273 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 13:46 EDT by Shahms E. King
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-25 12:46:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shahms E. King 2004-05-19 13:46:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040404 Firefox/0.8

Description of problem:
The tmscsim module is no longer shipped, even though (from everything
I can find) it's stable in 2.6 and was shipped in FC1.  There are a
lot of cards out there using this chipset, it would be nice to still
have support for it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install a Tekram SCSI card.
2. Find out there is no driver.

Additional info:
Comment 1 Shahms E. King 2004-05-19 22:48:32 EDT
I've since recompiled the 2.6.6-1.370 source rpm with
CONFIG_SCSI_DC390T enabled and, from what I can tell, it works, with
some caveats:

The current (2.6.6-1.370) RawHide kernel works with the tmscsim module
(from what I can tell).  The only thing I have attached to it is a
CD-ROM drive and so I can't tell if the problems I'm having are
related to that or the driver.  I can mount and read data CDs w/o a
problem, playing audio cds works but ripping them with cdda2wav and
cdparanoia does not (same problems others were having for IDE or USB
drives). Ripping with cdrdao works, however. Since Sound Juicer uses
gstreamer which uses libcdparanoia to rip, none of those work either.
Comment 2 og 2004-05-20 13:05:51 EDT
if you had tmscsim in your /etc/modules.conf of FC1 an update
installation will produce an empty grub.conf since initrd will fail to run
Comment 3 Shahms E. King 2004-05-23 12:22:27 EDT
A little bit more information:

After swapping out my Tekram adapter for an Adaptec, I discovered that
the tmscsim module works as well as (if not better than) the aic7xxx
module.  Given this, Arjan, would it be possible to see the tmscsim
module enabled in the RawHide builds?  It'd be nice to get it included
in an errata, but should probably see a little more testing in RawHide
first.
Comment 4 Dave Jones 2004-05-25 08:33:31 EDT
*** Bug 124273 has been marked as a duplicate of this bug. ***
Comment 5 Shahms E. King 2004-06-25 12:46:00 EDT
I just pulled down the latest RawHide kernel and the moduled is
present, I'm going to mark this as RESOLVED RAWHIDE and move on. 
Thank You Arjan.

Note You need to log in before you can comment on or make changes to this bug.