Bug 124273 - No module tmscsim found
No module tmscsim found
Status: CLOSED DUPLICATE of bug 123616
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-25 08:28 EDT by Kriton Kyrimis
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kriton Kyrimis 2004-05-25 08:28:46 EDT
Description of problem:
I just upgraded from Fedora Core 1 to Fedora Core 2. After the first
reboot, Fedora Core was no longer among the options offered by GRUB!
Booting from the rescue CD and looking at upgrade.log, I saw that the
installation of kernel-2.6.5-1.358.i686.rpm had failed with the
following error:

No module tmscsim found for kernel 2.6.5-1.358, aborting.

With a little help from Google, I found that this was SCSI
controller-related, so I was able to regain my system by removing my
SCSI controller, which was fortunately unused, and reinstalling the
kernel. However, I am sure that this is a showstopper for anyone who
is even more clueless than me, or happen to need their SCSI controller!

Version-Release number of selected component (if applicable):
2.6.5-1.358

How reproducible:
Always.

Steps to Reproduce:
1. Install a DAWICONTROL DC-2974 PCI (or similar, presumably--see
notes) SCSI controller on a system running Fedora Core 1.
2. Upgrade to Fedora Core 2.
  
Actual results:
Mkinitrd fails during the post-install phase with the message
mentioned above, and grub.conf is not updated to boot the new kernel.

Expected results:
Mkinitrd should succeed, and grub.conf should be properly updated.

Additional info:
By editing grub.conf by hand, I was able to boot into the system
without removing the SCSI controller. When I tried to reinstall the
kernel RPM by hand, I got the same error. Ditto for running mkinitrd
by hand. This is why I claim that this is "always" reproducible.

The controller is a DAWICONTROL DC-2974 PCI, which, according to the
manufacturer's web site, uses an AMD AM53C974A chip. 

My computer is a 2GHz Pentium 4.
Comment 1 Dave Jones 2004-05-25 08:33:27 EDT

*** This bug has been marked as a duplicate of 123616 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:43 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.