Bug 123630 - Keyboard layouts no longer work
Keyboard layouts no longer work
Status: CLOSED DUPLICATE of bug 123626
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 14:45 EDT by Nicholas Allen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicholas Allen 2004-05-19 14:45:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
When I start a GNOME session on Fedora Core 2 I get 5 or 6 error messages popping up. All messages are the same and say:

Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation
60700000

It asks me to add the output of two commands so here they are:

xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "gb", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "gb", "", ""
[test@kickass test]$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [gb]
 model = pc105
 overrideSettings = false
 options = []


Also when I run KDE and go to the keyboard configuration in control centre there are no keyboards or keyboard layouts to choose. This used to work in FC1.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Log in to GNOME after upgrading FC1 to FC2
2.
3.
    

Actual Results:  Get error messages. Cannot change keyboard layouts.

Expected Results:  Should not get error messages. Should be able to change keyboard layouts.

Additional info:
Comment 1 Magnus Feuer 2004-05-19 20:48:39 EDT
There is a similar problem with kxkb, stemming from the fact that 
xfree86 is now called xorg. 
To fix: 
cd /etc/X11/xkb/rules/ 
ln xorg.lst xfree86.lst 
ln xorg.xml xfree86.xml 
  
 
Comment 2 Miloslav Trmac 2004-05-20 03:13:47 EDT

*** This bug has been marked as a duplicate of 123626 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:03:19 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.