Bug 123626 - Error activating XKB configuration. Probably internal X server problem.
Summary: Error activating XKB configuration. Probably internal X server problem.
Status: CLOSED DUPLICATE of bug 120858
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11   
(Show other bugs)
Version: 2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL: http://penguinsolutions.org/images/Sc...
Whiteboard:
Keywords:
: 123630 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-19 18:41 UTC by Clint Harshaw
Modified: 2007-11-30 22:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:03:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Clint Harshaw 2004-05-19 18:41:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
When Gnome starts the following error appears in a window:
Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation
60700000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb

When I run the two commands listed I get these responses:

$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us", "", ""

$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [us]
 model = pc105
 overrideSettings = false
 options = []

This is on an upgrade from FC1 with all updates to FC2 on a Sony Vaio
laptop model number PCG-FX370k

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot laptop
2. log in, startx (or if runlevel 5, log in and let X start on its own)
3. error appears on desktop
4. I see no symptoms after closing the window
    

Actual Results:  error window appears as described above.

Expected Results:  error window should not appear

Additional info:

$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us", "", ""

$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [us]
 model = pc105
 overrideSettings = false
 options = []

Comment 1 Flavio Cardone 2004-05-19 23:24:20 UTC
Bug also happens to me... I would say that this bug should be treated
with "high" priority, as it prevents users from writing with different
keyboards, which is quite a mess if you have to write texts in many
different languages...

Comment 2 Clint Harshaw 2004-05-19 23:56:30 UTC
Follow-up to my original post:

The error does *not* appear when I log in to KDE.

Comment 3 Clint Harshaw 2004-05-20 00:12:21 UTC
I have changed this from a kudzu bug to a Gnome desktop bug, since it
is not consistent on KDE.

Comment 4 Flavio Cardone 2004-05-20 00:18:56 UTC
Yes, no error message is *shown* when you log into KDE, however, it
still *happens* - try adding an additional keyboard layout: none will
be available. If you log in to GNOME, then you get the error message
explaining why you don't have any keyboard available. I used three
keyboard layouts on KDE before installing FC2. After installing, on
the lower right side, where I should have my keyboards, I just had
"err" written. Go to the K Menu > Preferences > Control Centre >
Regional&Accessibility > Keyboard Layout - and you will see that no
keyboard layout is available. 

The bug is NOT Gnome Desktop only - it happens also on KDE!!!!

Comment 5 Jack Spaar 2004-05-20 01:39:04 UTC
Solution is:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=120858#c7

Comment 6 Flavio Cardone 2004-05-20 06:33:02 UTC
Yes, the problem is solved in that bug. What one must do is add a
symlink to xorg.lst in the rules directory:

cd /usr/X11R6/lib/X11/xkb/rules
ln -s xorg.lst xfree86.lst

I had already spotted that the directory contained a symlink from
xfree86 to xorg, but it seems that you also need one from xfree86.lst
to xorg.lst - I wonder if you also need one to the other "xorgs"

Comment 7 Miloslav Trmac 2004-05-20 07:13:49 UTC
*** Bug 123630 has been marked as a duplicate of this bug. ***

Comment 8 Miloslav Trmac 2004-05-20 07:22:16 UTC
*** Bug 123702 has been marked as a duplicate of this bug. ***

Comment 9 Mike A. Harris 2004-05-20 08:40:10 UTC

*** This bug has been marked as a duplicate of 120858 ***

Comment 10 Red Hat Bugzilla 2006-02-21 19:03:19 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.