Bug 1236447 - Update qemu-kvm-rhev package for new SLOF
Summary: Update qemu-kvm-rhev package for new SLOF
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: ppc64le
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: David Gibson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1225720
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-29 03:55 UTC by David Gibson
Modified: 2015-12-04 16:47 UTC (History)
10 users (show)

Fixed In Version: qemu-kvm-rhev-2.3.0-8.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-04 16:47:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description David Gibson 2015-06-29 03:55:11 UTC
Description of problem:

In bug 1225720 we have updated the SLOF package to match the version used in the upstream qemu we're now based on.  However, we need to updated the qemu-kvm-rhev spec file to pull in the new SLOF.  Currently it has a hard version dependency on the old version

Version-Release number of selected component (if applicable):

qemu-kvm-rhev-2.3.0-6.el7

Comment 2 Miroslav Rezanina 2015-07-08 10:54:25 UTC
Fix included in qemu-kvm-rhev-2.3.0-8.el7

Comment 4 Qunfang Zhang 2015-07-31 10:21:51 UTC
Checking the qemu-kvm.spec in the qemu-kvm-rhev-2.3.0-13 source package:

# grep SLOF qemu-kvm-13.spec
%global SLOF_gittagdate 20150313
Requires: SLOF = %{SLOF_gittagdate}
# Provided by package SLOF
- kvm-rhel-Update-package-version-for-SLOF-dependency.patch [bz#1236447]
  (Update qemu-kvm-rhev package for new SLOF)
- Change SLOF Requires for the new version number
  n-v-r, and 'dist' tag of SLOF, all to fix RHBZ#855252.
- add versioned dependency from qemu-system-ppc to SLOF (BZ#855252)

And also did the following experiments:

1. Host installed SLOF-20150313, qemu-kvm-rhev-2.3.0-13:
(1) Downgrade/Upgrade between qemu-kvm-rhev-2.3.0-12 and -13 successfully.
(2) Downgrade SLOF to SLOF-20140630 fail and prompt:
	SLOF = 20150313 is needed by (installed) qemu-kvm-rhev-10:2.3.0-13.el7.ppc64le
(3) Downgrade qemu-kvm-rhev to qemu-kvm-rhev-2.3.0-7, fail and prompt:
	SLOF = 20140630 is needed by qemu-kvm-rhev-10:2.3.0-7.el7.ppc64le

2. Host installed SLOF-20140630, qemu-kvm-rhev-2.3.0-7:
(1) Upgrade qemu-kvm-rhev to qemu-kvm-rhev-2.3.0-13, fail and prompt:
	SLOF = 20150313 is needed by qemu-kvm-rhev-10:2.3.0-13.el7.ppc64le

Based on above, I will set the status to VERIFIED. Anything wrong, please fix me. Thanks.

Comment 6 errata-xmlrpc 2015-12-04 16:47:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.