Bug 855252 - qemu-system-ppc package should have a versioned dependency on SLOF
qemu-system-ppc package should have a versioned dependency on SLOF
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
18
All Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-07 02:16 EDT by David Gibson
Modified: 2013-01-09 07:07 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-25 12:40:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Gibson 2012-09-07 02:16:33 EDT
Description of problem:

The qemu-system-ppc64 -M pseries virtual machine in qemu requires an image of the SLOF firmware.  In Fedora that firmware is packaged separately in the SLOF package.  However changes in the qemu virtual machine often require updates to the SLOF firmware, so the SLOF package needs to be sufficiently up to date w.r.t. the qemu package.  At present, this is not the case and the pseries virtual machine will crash during boot depending on guest details.  Bug 855246 is about updating the SLOF package to a version suitable for the current qemu package.

However to prevent this sort of problem in future - or other confusing failures due to updating qemu without updating SLOF - the qemu package should have a version dependency in its Require line for SLOF.  For the current qemu, >= 20120731 would be suitable (as soon as the 20120731 version of the SLOF package is actually built).
Comment 1 Paolo Bonzini 2012-09-14 06:55:12 EDT
Fixed in commit 1fbcf81188e4007b7c532933060d3267302e3b84.
Comment 2 David Gibson 2012-09-16 21:39:20 EDT
Looks good, thanks.
Comment 3 David Gibson 2012-09-17 23:19:29 EDT
Uh, actually, no.  I can't see why, but when I build the package from source on ppc, I get a requires line containing a _literal_ %{SLOF-gittagdate} instead of it being properly expanded.

vpl1:~$ rpm -qpR rpmbuild/RPMS/ppc64/qemu-system-ppc-1.2.0-4.fc18.ppc64.rpm  | grep SLOF
SLOF = 0.1.git%{SLOF-gittagdate}
Comment 4 Richard W.M. Jones 2012-09-18 03:51:16 EDT
(In reply to comment #3)
> Uh, actually, no.  I can't see why, but when I build the package from source
> on ppc, I get a requires line containing a _literal_ %{SLOF-gittagdate}
> instead of it being properly expanded.
> 
> vpl1:~$ rpm -qpR rpmbuild/RPMS/ppc64/qemu-system-ppc-1.2.0-4.fc18.ppc64.rpm 
> | grep SLOF
> SLOF = 0.1.git%{SLOF-gittagdate}

Note that I've already fixed this in Rawhide.

Some discussion going on about how to correctly fix this
(ie. should we include the git date in the version instead
of "0"), so it's not in F18 yet.
Comment 5 Fedora Update System 2012-09-19 16:06:01 EDT
qemu-1.2.0-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qemu-1.2.0-8.fc18
Comment 6 Fedora Update System 2012-09-20 01:58:34 EDT
Package qemu-1.2.0-8.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-1.2.0-8.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14391/qemu-1.2.0-8.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-09-21 15:28:37 EDT
qemu-1.2.0-9.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qemu-1.2.0-9.fc18
Comment 8 David Gibson 2012-09-24 02:02:49 EDT
Looks good, thanks.
Comment 9 Fedora Update System 2012-09-25 12:40:21 EDT
qemu-1.2.0-9.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.