Bug 123649 - gdm login shows errors
gdm login shows errors
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 131103 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 16:07 EDT by Seth Reinoso
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-11 17:33:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Seth Reinoso 2004-05-19 16:07:46 EDT
Description of problem:
When starting gnome via gdm login I get the following error:
--------------- snip ------------------
Error activating XKB Configuration

X Server Version Data
The X.org foundation
607000

If you report this situation as a bug please include the result of 
xprop -root | grep XKB
gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb


---------------------------------------
The above suggested commands do not work.

Version-Release number of selected component (if applicable):
gdm-2.6.0.0-3

How reproducible:

very 
Steps to Reproduce:
1. Log in through gdm 

  
Actual results:

Error message box pops up with above error.

Expected results:
Gnome starts normally.

Additional info:
Comment 1 Alan Cox 2004-05-21 19:30:49 EDT
Is this an upgrade from Fedora 2 beta ?
Comment 2 Seth Reinoso 2004-05-21 23:15:44 EDT
upgrade from FC1 to FC2 
Comment 3 Eric Harley 2004-06-25 10:12:42 EDT
see bug 120858 - others have also had this problem. I think they have
also said it's not limited to the i386 platform.

Some could clear it up by removing or changing an options line in
xorg.conf, for others (myself included) this didn't work.  It happened
to me with a fresh install of FC2, after updating some packages with
apt.  It didn't occur when logging in as root, but did occur for other
non-root accounts I created.  I got rid of it by reinstalling and not
downloading any updates yet.  Sounds like Andrew Rechenberg and others
are on the trail -- I'm just going to sit tight and be careful about
what I update until it sounds like someone has managed to fix it.
Comment 4 Eric Doutreleau 2004-08-31 05:58:02 EDT
i still get this bug too with a fresh install of fc2.
i disable all client in the gnome-session default file but i still got
this infamous warning and the gnome desktop is messed
Comment 5 Eric Doutreleau 2004-09-06 08:53:29 EDT
well i don't have the problem for a local user but for an nfs based user.
Comment 6 Edwin T. Floyd 2004-10-19 16:10:21 EDT
Same problem is happening to me.  Fresh install of FC2 with all the
latest up2date packages installed.  Gnome works fine for root, but
fails as above for non-root users.  I have tried everything in Bug
120858 to no avail.  One twist - KDE appears to work in that it
doesn't throw a pop-up message, but applications will not start.  This
bug appears to be a duplicate of Bug 131103.
Comment 7 Marco Pesenti Gritti 2004-10-22 06:31:56 EDT
*** Bug 131103 has been marked as a duplicate of this bug. ***
Comment 8 Matthew Miller 2005-04-26 12:36:31 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 9 Ray Strode [halfline] 2005-05-11 17:33:49 EDT
Hi,

This bug is being closed because it has been in the NEEDINFO state for a long
time now.  Feel free to reopen the bug report if the problem still happens for
you and you can provide any information that was requested.

Note You need to log in before you can comment on or make changes to this bug.