Bug 123687 - anaconda/install fails with selinux enabled with /mnt/syslinux/selinix duplicate message
anaconda/install fails with selinux enabled with /mnt/syslinux/selinix duplic...
Status: CLOSED DUPLICATE of bug 127713
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2004-05-19 21:13 EDT by Tom London
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:03:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Anaconda dump/traceback info written to floppy.... (724.02 KB, text/plain)
2004-05-19 21:16 EDT, Tom London
no flags Details

  None (edit)
Description Tom London 2004-05-19 21:13:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
I'm attempting to 'upgrade' a FC2T3 to FC2 using the downloaded (and
verified) FC2 CD images, entering 'selinux' at the boot prompt.

anaconda fails, both when attemping to 'upgrade existing' and with a
fresh install (I tried to reuse the existing partitions).

Here is the traceback info:
Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1048, in handleRenderCallback
  File "/usr/lib/anaconda/iw/progress_gui.py", line 242, in renderCallback
  File "/usr/lib/anaconda/gui.py", line 763, in nextClicked
  File "/usr/lib/anaconda/dispatch.py", line 169, in gotoNext
  File "/usr/lib/anaconda/dispatch.py", line 237, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 737, in doPreInstall
    os.mkdir(instPath + "/selinux")
OSError: [Errno 17] File exists: '/mnt/sysimage/selinux'

I attach the complete 'anacdump.txt' as well.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Using FC2 CDs, attempt to install over existing FC3T3/selinux
system (enter 'selinux' at anaconda prompt).
2. Select either 'upgrade' or 'install'
3. If 'install' retain existing partitions (I haven't tried a complete
wipe out of the drive).

Actual Results:  Anaconda abort message described above, with options
to save to floppy. File 'anacdump.txt' attached.

Additional info:
Comment 1 Tom London 2004-05-19 21:16:36 EDT
Created attachment 100364 [details]
Anaconda dump/traceback info written to floppy....
Comment 2 Jeremy Katz 2004-05-19 22:48:26 EDT
Upgrades from test releases to final releases aren't supported... 
I'll look at this eventually, though, as it will affect FC2 with
SELinux -> FC3 upgrades.
Comment 3 Tom London 2004-05-19 23:21:13 EDT
OK. I'll do the 'wipe it clean' thing.

Before I clobber this, is there any additional information, settings,
etc. that would help you?
Comment 4 Tom London 2004-07-14 10:12:03 EDT
Hit this bug again going from FC2 -> FC3t1.

I'm guessing 'anaconda' needs to remove /selinux 
if it already exists prior to doing its usual
Comment 5 Phil Schaffner 2004-07-27 12:42:15 EDT
Also seeing this bug on FC2 -> FC3T1 upgrade attempt.  Repeated
attempts to save traceback to floppy failed (thought I saw this
flagged as fixed in rawhide), but looks very much like the one in the
attachment above.  FC2 was running with selinux disabled.
Comment 6 Jeremy Katz 2004-07-27 13:37:36 EDT

*** This bug has been marked as a duplicate of 127713 ***
Comment 7 Red Hat Bugzilla 2006-02-21 14:03:20 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.