Bug 123690 - pcmcia does not work by default
pcmcia does not work by default
Status: CLOSED DUPLICATE of bug 123713
Product: Fedora
Classification: Fedora
Component: pcmcia-cs (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 21:59 EDT by Alex Deucher
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Deucher 2004-05-19 21:59:58 EDT
Description of problem:
I have an IBM thinkpad X24 with built in e100 ethernet and an orinoco
pcmcia wifi card.  I usually only use the wifi card, however, pcmcia
refuses to work from the init scripts when the computer boots up.  It
claims to load ok according to the init script, but it doesn't work. 
I suspected it might be a problem with the order so I tried starting
pcmcia before networking, but that didn't help either.  I solved the
problem by adding the following lines to my rc.local:
/sbin/modprobe -r orinoco_cs
/sbin/service pcmcia restart
/sbin/service network restart
/sbin/service netfs restart
after that, everything works.  PCMCIA has always kind of seemed like
black magic to me.  I wish I knew more about the problem.

Version-Release number of selected component (if applicable):
pcmcia-cs-3.2.7-1.5

How reproducible:
everytime.

Steps to Reproduce:
1. boot the computer
  
Actual results:
pcmcia claims to load, but actually doesn't.

Expected results:
pcmcia subsystem should load, allowing access to pcmcia cards.

Additional info:
dmesg (including fix from above, MAC's removed):
Linux version 2.6.5-1.358 (bhcompile@bugs.build.redhat.com) (gcc
version 3.3.3 20040412 (Red Hat Linux 3.3.3-7)) #1 Sat May 8 09:04:50
EDT 2004
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009f000 (usable)
 BIOS-e820: 000000000009f000 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000dc000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000000ff70000 (usable)
 BIOS-e820: 000000000ff70000 - 000000000ff7a000 (ACPI data)
 BIOS-e820: 000000000ff7a000 - 000000000ff7c000 (ACPI NVS)
 BIOS-e820: 000000000ff7c000 - 0000000010000000 (reserved)
 BIOS-e820: 00000000ff800000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
255MB LOWMEM available.
zapping low mappings.
On node 0 totalpages: 65392
  DMA zone: 4096 pages, LIFO batch:1
  Normal zone: 61296 pages, LIFO batch:14
  HighMem zone: 0 pages, LIFO batch:1
DMI present.
IBM machine detected. Enabling interrupts during APM calls.
IBM machine detected. Disabling SMBus accesses.
ACPI: RSDP (v002 IBM                                       ) @ 0x000f73b0
ACPI: XSDT (v001 IBM    TP-1D    0x00001290  LTP 0x00000000) @ 0x0ff705d3
ACPI: FADT (v001 IBM    TP-1D    0x00001290 IBM  0x00000001) @ 0x0ff70617
ACPI: SSDT (v001 IBM    TP-1D    0x00001290 MSFT 0x0100000d) @ 0x0ff706cb
ACPI: ECDT (v001 IBM    TP-1D    0x00001290 IBM  0x00000001) @ 0x0ff79f87
ACPI: BOOT (v001 IBM    TP-1D    0x00001290  LTP 0x00000001) @ 0x0ff79fd8
ACPI: DSDT (v001 IBM    TP-1D    0x00001290 MSFT 0x0100000d) @ 0x00000000
ACPI: PM-Timer IO Port: 0x1008
Built 1 zonelists
Kernel command line: ro root=LABEL=/ rhgb quiet
mapped 4G/4G trampoline to ffff3000.
Initializing CPU#0
CPU 0 irqstacks, hard=02345000 soft=02344000
PID hash table entries: 1024 (order 10: 8192 bytes)
Detected 732.751 MHz processor.
Using pmtmr for high-res timesource
Console: colour VGA+ 80x25
Memory: 255940k/261568k available (1540k kernel code, 4912k reserved,
599k data, 144k init, 0k highmem)
Calibrating delay loop... 1454.08 BogoMIPS
Security Scaffold v1.0.0 initialized
SELinux:  Initializing.
SELinux:  Starting in permissive mode
There is already a security framework initialized, register_security
failed.
Failure registering capabilities with the kernel
selinux_register_security:  Registering secondary module capability
Capability LSM initialized
Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
CPU:     After generic identify, caps: 0383f9ff 00000000 00000000 00000000
CPU:     After vendor identify, caps: 0383f9ff 00000000 00000000 00000000
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 512K
CPU:     After all inits, caps: 0383f1ff 00000000 00000000 00000040
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: Intel(R) Pentium(R) III Mobile CPU      1133MHz stepping 01
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xfd8fe, last bus=8
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20040326
ACPI: IRQ9 SCI: Edge set to Level Trigger.
ACPI: Found ECDT
ACPI: Could not use ECDT
    ACPI-1133: *** Error: Method execution failed
[\_SB_.PCI0.LPC_.EC__._INI] (Node 11eb5a9c), AE_NOT_EXIST
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 6 9 10 *11)
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 6 9 10 11)
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 6 9 10 *11)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 6 9 10 *11)
ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 6 9 10 *11)
ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 6 9 10 11)
ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 6 9 10 11)
ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 6 9 10 11)
ACPI: PCI Root Bridge [PCI0] (00:00)
PCI: Probing PCI hardware (bus 00)
Transparent bridge - 0000:00:1e.0
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: Embedded Controller [EC] (gpe 28)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.AGP_._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PCI1._PRT]
Linux Plug and Play Support v0.97 (c) Adam Belay
usbcore: registered new driver usbfs
usbcore: registered new driver hub
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 11
ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 11
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 5
ACPI: PCI Interrupt Link [LNKE] enabled at IRQ 11
PCI: Using ACPI for IRQ routing
PCI: if you experience problems, try using option 'pci=noacpi' or even
'acpi=off'
Simple Boot Flag at 0x35 set to 0x1
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
apm: overridden by ACPI.
audit: initializing netlink socket (disabled)
audit(1085016777.4294966623:0): initialized
Total HugeTLB memory allocated, 0
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
SELinux:  Registering netfilter hooks
Initializing Cryptographic API
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
ACPI: Processor [CPU] (supports C1 C2 C3, 8 throttling states)
ACPI: Thermal Zone [THM0] (45 C)
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Real Time Clock Driver v1.12
Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Detected an Intel 830M Chipset.
agpgart: Maximum main memory to use for agp memory: 203M
agpgart: AGP aperture is 256M @ 0xd0000000
Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing enabled
ttyS1 at I/O 0x2f8 (irq = 3) is a NS16550A
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
divert: not allocating divert_blk for non-ethernet device lo
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with
idebus=xx
ICH3M: IDE controller at PCI slot 0000:00:1f.1
PCI: Enabling device 0000:00:1f.1 (0005 -> 0007)
ICH3M: chipset revision 2
ICH3M: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x1860-0x1867, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0x1868-0x186f, BIOS settings: hdc:pio, hdd:pio
hda: IC25N030ATCS04-0, ATA DISK drive
Using cfq io scheduler
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: max request size: 128KiB
hda: 58605120 sectors (30005 MB) w/1768KiB Cache, CHS=62016/15/63,
UDMA(100)
 hda: hda1 hda2 hda3 hda4
ide-floppy driver 0.99.newide
usbcore: registered new driver hiddev
usbcore: registered new driver hid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
mice: PS/2 mouse device common for all mice
serio: i8042 AUX port at 0x60,0x64 irq 12
input: PS/2 Generic Mouse on isa0060/serio1
serio: i8042 KBD port at 0x60,0x64 irq 1
input: AT Translated Set 2 keyboard on isa0060/serio0
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
NET: Registered protocol family 2
IP: routing cache hash table of 2048 buckets, 16Kbytes
TCP: Hash tables configured (established 16384 bind 32768)
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
ACPI: (supports S0 S3 S4 S5)
checking if image is initramfs...it isn't (no cpio magic); looks like
an initrd
Freeing initrd memory: 187k freed
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
RAMDISK: Compressed image found at block 0
VFS: Mounted root (ext2 filesystem).
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Freeing unused kernel memory: 144k freed
SELinux:  Disabled at runtime.
SELinux:  Unregistering netfilter hooks
NET: Registered protocol family 10
Disabled Privacy Extensions on device 022db720(lo)
IPv6 over IPv4 tunneling driver
divert: not allocating divert_blk for non-ethernet device sit0
[drm] Initialized radeon 1.9.0 20020828 on minor 0
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 4x mode
ACPI: AC Adapter [AC] (off-line)
ACPI: Battery Slot [BAT0] (battery present)
ACPI: Power Button (FF) [PWRF]
ACPI: Lid Switch [LID]
ACPI: Sleep Button (CM) [SLPB]
USB Universal Host Controller Interface driver v2.2
uhci_hcd 0000:00:1d.0: UHCI Host Controller
PCI: Setting latency timer of device 0000:00:1d.0 to 64
uhci_hcd 0000:00:1d.0: irq 11, io base 00001800
uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
uhci_hcd 0000:00:1d.1: UHCI Host Controller
PCI: Setting latency timer of device 0000:00:1d.1 to 64
uhci_hcd 0000:00:1d.1: irq 11, io base 00001820
uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 2
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
uhci_hcd 0000:00:1d.2: UHCI Host Controller
PCI: Setting latency timer of device 0000:00:1d.2 to 64
uhci_hcd 0000:00:1d.2: irq 11, io base 00001840
uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 3
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
EXT3 FS on hda1, internal journal
device-mapper: 4.1.0-ioctl (2003-12-10) initialised: dm@uk.sistina.com
Adding 718192k swap on /dev/hda3.  Priority:-1 extents:1
kjournald starting.  Commit interval 5 seconds
EXT3 FS on hda2, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
SCSI subsystem initialized
inserting floppy driver for 2.6.5-1.358
Floppy drive(s): fd0 is 1.44M
floppy0: no floppy controllers found
e100: Intel(R) PRO/100 Network Driver, 3.0.17
e100: Copyright(c) 1999-2004 Intel Corporation
divert: allocating divert_blk for eth0
e100: eth0: e100_probe: addr 0xc0200000, irq 11, MAC addr
divert: freeing divert_blk for eth0
ip_tables: (C) 2000-2002 Netfilter core team
e100: Intel(R) PRO/100 Network Driver, 3.0.17
e100: Copyright(c) 1999-2004 Intel Corporation
divert: allocating divert_blk for eth0
e100: eth0: e100_probe: addr 0xc0200000, irq 11, MAC addr
00:D0:59:CE:CE:B5
orinoco.c 0.13e (David Gibson <hermes@gibson.dropbear.id.au> and others)
Linux Kernel Card Services
  options:  [pci] [cardbus] [pm]
orinoco_cs.c 0.13e (David Gibson <hermes@gibson.dropbear.id.au> and
others)
NET: Registered protocol family 23
lp: driver loaded but no devices found
eth0: no IPv6 routers present
unloading Kernel Card Services
inserting floppy driver for 2.6.5-1.358
Floppy drive(s): fd0 is 1.44M
floppy0: no floppy controllers found
Linux Kernel Card Services
  options:  [pci] [cardbus] [pm]
Yenta: CardBus bridge found at 0000:02:03.0 [1014:0185]
Yenta: ISA IRQ mask 0x0498, PCI irq 11
Socket status: 30000410
Yenta: CardBus bridge found at 0000:02:03.1 [1014:0185]
Yenta: ISA IRQ mask 0x0498, PCI irq 5
Socket status: 30000006
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x170-0x177 0x370-0x377
0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
cs: memory probe 0xa0000000-0xa0ffffff: clean.
orinoco.c 0.13e (David Gibson <hermes@gibson.dropbear.id.au> and others)
orinoco_cs.c 0.13e (David Gibson <hermes@gibson.dropbear.id.au> and
others)
divert: allocating divert_blk for eth1
eth1: Station identity 
eth1: Looks like a Lucent/Agere firmware version 7.28
eth1: Ad-hoc demo mode supported
eth1: IEEE standard IBSS ad-hoc mode supported
eth1: WEP supported, 104-bit key
eth1: MAC address 
eth1: Station name "HERMES I"
eth1: ready
eth1: index 0x01: Vcc 5.0, irq 3, io 0x0100-0x013f
ip_tables: (C) 2000-2002 Netfilter core team
eth1: New link status: Disconnected (0002)
ip_tables: (C) 2000-2002 Netfilter core team
eth1: New link status: Connected (0001)
ip_tables: (C) 2000-2002 Netfilter core team
Disabled Privacy Extensions on device 022db720(lo)
ip_tables: (C) 2000-2002 Netfilter core team
eth1: New link status: Connected (0001)
eth1: New link status: Disconnected (0002)
ip_tables: (C) 2000-2002 Netfilter core team
eth1: New link status: Connected (0001)
eth1: no IPv6 routers present
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 4x mode
PCI: Enabling device 0000:00:1f.5 (0000 -> 0001)
PCI: Setting latency timer of device 0000:00:1f.5 to 64
intel8x0_measure_ac97_clock: measured 49553 usecs
intel8x0: clocking to 48000

lspci:
00:00.0 Host bridge: Intel Corp. 82830 830 Chipset Host Bridge (rev 04)
00:01.0 PCI bridge: Intel Corp. 82830 830 Chipset AGP Bridge (rev 04)
00:1d.0 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #1) (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #2) (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #3) (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BAM/CAM PCI Bridge (rev 42)
00:1f.0 ISA bridge: Intel Corp. 82801CAM ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801CAM IDE U100 (rev 02)
00:1f.3 SMBus: Intel Corp. 82801CA/CAM SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801CA/CAM AC'97
Audio Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon
Mobility M6 LY
02:03.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 80)
02:03.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 80)
02:05.0 Communication controller: Lucent Microelectronics WinModem 56k
(rev 01)
02:08.0 Ethernet controller: Intel Corp. 82801CAM (ICH3) PRO/100 VE
(LOM) Ethernet Controller (rev 42)
Comment 1 Alex Deucher 2004-05-20 09:34:12 EDT
looks like the same bug as 123713

*** This bug has been marked as a duplicate of 123713 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:20 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.