Bug 123713 - FC2 Final yenta_socket not loaded so PCMCIA broken
FC2 Final yenta_socket not loaded so PCMCIA broken
Status: CLOSED DUPLICATE of bug 123457
Product: Fedora
Classification: Fedora
Component: pcmcia-cs (Show other bugs)
2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
: 123690 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-20 04:33 EDT by Alex Bibiano
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Bibiano 2004-05-20 04:33:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
brip1; .NET CLR 1.1.4322)

Description of problem:
As in bug 121742, on Fedora Core 2 installed on Dell Inspiron 8200 the
kernel module yenta_socket isn't loaded and therefore my PCMCIA
devices including my builtin wireless NIC don't work.

All other required modules are loaded such as ds and pcmcia_core. The
drivers for my wireless card are loaded as well hermes,orinoco, and
orinoco_cs.

This is because anaconda stuck a "alias eth1 orinoco_cs" in my
/etc/modprobe.conf.



Version-Release number of selected component (if applicable):
pcmcia-cs-3.2.7-1.5

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core 2
2. Start it

    

Actual Results:  Cardmgr[2480]: No sockects found

Expected Results:  Load kernel module yenta_socket 

Additional info:

The current work around is the following:

modprobe yenta_socket
/etc/init.d/pcmcia restart
Comment 1 Alex Deucher 2004-05-20 09:34:15 EDT
*** Bug 123690 has been marked as a duplicate of this bug. ***
Comment 2 Earl Terwilliger 2004-05-20 13:18:53 EDT
Just loaded FC2 (final) and have the same/similar problem. 
I have a Generic i82365-compatible PCMCIA controller" and a wireless 
PCMCIA orinoco card. At PCMCIA start-up I get the no sockets found 
error too.  
 
If I manually try: 
 
 modprobe i82365 
 service pcmcia restart 
 service network restart 
 
it works fine. SO it looks as if it is not just related to 
yenta-socket... 
 
 
Comment 3 Greg Breland 2004-05-20 13:23:12 EDT
I'm having the same problem with my Compaq Presario 1930.  Cardmgr
couldn't find any sockets so my Xircom 10/100 card wouldn't work. 
loading yenta_socket and restarting Cardmgr caused it to find my two
sockets.  Then running kuduz found the NIC and I'm good to go.

BTW, this laptop worked fine with RH9 and FC1, but hasn't worked on
any of the FC2-testx series.
Comment 4 Alex Bibiano 2004-05-20 17:17:41 EDT
if I comment in the file /etc/modprobe.conf the orinoco_cs line, it
works OK.
Comment 5 Alan Cox 2004-05-21 20:07:56 EDT

*** This bug has been marked as a duplicate of 123457 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:03:21 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.