Bug 123697 - portmap contains name provide causing triggers to fire incorrectly
portmap contains name provide causing triggers to fire incorrectly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
: 127571 (view as bug list)
Depends On:
Blocks: 123680
  Show dependency treegraph
 
Reported: 2004-05-19 23:59 EDT by Glen
Modified: 2007-11-30 17:10 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-16 09:12:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to filter out DT_DEBUG (1.10 KB, patch)
2004-05-21 05:52 EDT, Paul Nasrat
no flags Details | Diff

  None (edit)
Description Glen 2004-05-19 23:59:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
When I run "rpm -e portmap", I get these errors:

error reading information on service portmap: No such file or directory
error:%prerun(portmap-4.0-59) scriptlet failed, exit status 1

Version-Release number of selected component (if applicable):
portmap-4.0-59

How reproducible:
Always

Steps to Reproduce:
1. Run "rpm -e portmap"
2.
3.
    

Actual Results:  It gives me the error I mentioned.

Expected Results:  I expected portmap to be removed.

Additional info:
Comment 1 Paul Nasrat 2004-05-20 01:56:24 EDT
Path failure on fc2 use /sbin/service rather than service

[pauln@enki tmp]$ rpm --scripts -q portmap
postinstall scriptlet (using /bin/sh):
/sbin/chkconfig --add portmap
/usr/sbin/groupadd -g 32 rpc > /dev/null 2>&1
/usr/sbin/useradd -c "Portmapper RPC user" -d / -g 32 -M -s
/sbin/nologin -u 32 rpc > /dev/null 2>&1
exit 0
preuninstall scriptlet (using /bin/sh):
if [ $1 = 0 ]; then
  service portmap stop > /dev/null 2>&1
  /sbin/chkconfig --del portmap
fi
postuninstall scriptlet (using /bin/sh):
if [ "$1" -ge "1" ]; then
  service portmap condrestart > /dev/null 2>&1
fi
Comment 2 Paul Nasrat 2004-05-20 02:24:26 EDT
This is not a path issue - SCRIPT_PATH is unaltered looks to be a
trigger misfiring:

rpm --triggers -q portmap
triggerpostun scriptlet (using /bin/sh) -- portmap <= portmap-4.0-22
/sbin/chkconfig --add portmap

from rpm -e -vv --nodeps portmap I get:

D:     erase: %trigger(portmap-4.0-59)	execv(/bin/sh) pid 4466

+ /sbin/chkconfig --add portmap

error reading information on service portmap: No such file or directory

D:     erase: waitpid(4466) rc 4466 status 100 secs 0.073

error: %trigger(portmap-4.0-59) scriptlet failed, exit status 1

Comment 3 Paul Nasrat 2004-05-20 07:31:22 EDT
portmap seems to have a %{name} level provides as triggers match
against all provides and Provides: %{name} matches all EVR it's being
fired

rpm -q --provides portmap
config(portmap) = 4.0-59
portmap
portmap = 4.0-59

I can't see Provides: %{name} or anything in the spec so need to
figure why the virtual is there.
Comment 4 Paul Nasrat 2004-05-20 09:36:49 EDT
Change component to rpm
Comment 5 Paul Nasrat 2004-05-20 13:28:12 EDT
bingo:

[pauln@enki pauln]$ file /sbin/portmap
/sbin/portmap: ELF 32-bit LSB shared object, Intel 80386, version 1
(SYSV), stripped

The provide here is due to SONAME adding:

  /* For DSO's, provide the basename of the file if DT_SONAME not
found. */
    if (!fc->skipProv && isDSO && !gotSONAME) {

All the following binaries are probably the same:

exim
finger
httpd
nscd
perl
perl-URI
portmap
postgresql-odbc
routed
rusers
squid
sudo
telnet
vsftpd
Comment 6 Paul Nasrat 2004-05-20 13:31:13 EDT
Note this is probably due to the executables being PIE.  Probably need
to teach rpm how to tell the difference if we can
Comment 7 Paul Nasrat 2004-05-21 05:52:13 EDT
Created attachment 100411 [details]
Patch to filter out DT_DEBUG

Tested this against rpm-4_3 branch and filtering for DT_DEBUG skips adding a
basename (usually == %{name}) of the PIE executable to Provides:
Comment 8 Paul Nasrat 2004-05-21 05:59:16 EDT
Jeff does this all look sane to you?
Comment 9 Thomas Woerner 2004-05-21 07:25:01 EDT
*** Bug 123680 has been marked as a duplicate of this bug. ***
Comment 10 Jeff Johnson 2004-06-16 09:12:32 EDT
The PIE patch is in latest rpm-4.3.2.
Comment 11 Bill Nottingham 2004-06-28 17:17:01 EDT
*** Bug 123680 has been marked as a duplicate of this bug. ***
Comment 12 Bill Nottingham 2004-07-09 16:55:01 EDT
*** Bug 127571 has been marked as a duplicate of this bug. ***
Comment 13 Jarkko 2004-07-10 04:31:04 EDT
What should I do to get ppp updated? Update rpm? Why the fix is not in
the updates?
Comment 14 Matthew Miller 2004-07-10 12:55:57 EDT
*** Bug 127554 has been marked as a duplicate of this bug. ***
Comment 15 Paul Nasrat 2004-07-10 14:16:18 EDT
Any chance of getting 4.3.2 as errata for fc2 and into buildroots?
Comment 19 Stefan Neufeind 2005-02-11 19:15:50 EST
Would really appreciate a release of a fixed rpm for fc2. Any chance?

Note You need to log in before you can comment on or make changes to this bug.