This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 123702 - missing file on xorg-x11 (xfree86.lst); xkb and related tools does not work
missing file on xorg-x11 (xfree86.lst); xkb and related tools does not work
Status: CLOSED DUPLICATE of bug 120858
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-20 01:01 EDT by Leon Ho
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Leon Ho 2004-05-20 01:01:20 EDT
Description of problem:
when xkb (setxkbmap) runs, it is trying read the rules file
xfree86.lst. The setxkbmap complains "Couldn't find rules file
(xfree86)". It will also lead to tools like kde's keyboard layout does
not work anymore.

Version-Release number of selected component (if applicable):


How reproducible:
everytime

Steps to Reproduce:
1. setxkbmap -symbols "en_US(pc105)+dev(basic)+group(shift_toggle)"
  
Actual results:
"Couldn't find rules file (xfree86)"

Expected results:
No error and ran successfully

Additional info:
ln -s /usr/X11R6/lib/X11/xkb/rules/xorg.lst
/usr/X11R6/lib/X11/xkb/rules/xfree86.lst fixes the problem
Comment 1 Miloslav Trmac 2004-05-20 03:22:13 EDT

*** This bug has been marked as a duplicate of 123626 ***
Comment 2 Mike A. Harris 2004-05-20 04:39:21 EDT

*** This bug has been marked as a duplicate of 120858 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:03:20 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.