Bug 1237068 - Ensure all parameters are passed to Tuskar as strings
Summary: Ensure all parameters are passed to Tuskar as strings
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin
Version: Director
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ga
: Director
Assignee: Dougal Matthews
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-30 10:11 UTC by Dougal Matthews
Modified: 2015-08-05 13:57 UTC (History)
7 users (show)

Fixed In Version: python-rdomanager-oscplugin-0.0.8-15.el7ost
Doc Type: Bug Fix
Doc Text:
Tuskar API expected all parameters to be strings, but since some of the parameters were passed as integer values, the API would reject those. With this update, all parameters are converted to strings before being sent to the API. As a result, the API accepts all parameters and the deployment works successfully.
Clone Of:
Environment:
Last Closed: 2015-08-05 13:57:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 238094 None None None Never
Red Hat Bugzilla 51990 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Dougal Matthews 2015-06-30 10:11:36 UTC
Description of problem:

Tuskar expects all parameters to be strings. Any CLI args that are ints will fail.



How reproducible:

    openstack overcloud deploy --plan overcloud --control-scale 1 --compute-scale 1 --ceph-storage-scale 1



Result:

    ERROR: openstack Invalid input for field/attribute value. Value: '1'. Wrong type. Expected '<type 'unicode'>', got '<type 'int'>' (



Expected:

    Successful deploy

Comment 3 Dougal Matthews 2015-06-30 10:25:43 UTC
This regression happened as a result of the work on this bug: https://bugzilla.redhat.com/show_bug.cgi?id=1193922

Comment 7 errata-xmlrpc 2015-08-05 13:57:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.