Bug 123716 - false alarm if invalid symlink is present in /etc/sysconfig/network-scripts
Summary: false alarm if invalid symlink is present in /etc/sysconfig/network-scripts
Status: CLOSED DUPLICATE of bug 98252
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-network   
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-20 09:19 UTC by Pavel Tsekov
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:03:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pavel Tsekov 2004-05-20 09:19:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
I've upgraded my FC1 installation to FC2 test 3. Now
as I run system-config-network and try to save the 
changes (say I add a entry the hosts file) a warning
dialog pops up with the following text in it:

Warning

system-config-network:

Error saving configuration!
[Errno 2] No such file or directory: '//etc/sysconfig/
network-scripts/ifcfg-lo.rpmsave'

Though the warning indicates that the configuration wasn't
saved it turns out that it is indeed saved!

The file '/etc/sysconfig/network-scripts/ifcfg-lo.rpmsave'
is present and is a broken symbolic link like this:

  ifcfg-lo.rpmsave -> ../networking/ifcfg-lo

I guess this file was left by the upgrade process so maybe
this is not really a system-config-network problem, but the
fact that system-config-network says an error occured when
there was none made me post this bugreport.



Version-Release number of selected component (if applicable):
system-config-network-tui-1.3.16-1 system-config-network-1.3.16-1

How reproducible:
Always

Steps to Reproduce:
1. Create an invalid symlink in /etc/sysconfig/network-scripts

2. Run system-config-network and change something - for example
   add a new entry to hosts file

3. Try to save the change
    

Actual Results:  A warning box pops up saying that it failed to save the 
configuration, but the configuration is saved.

Expected Results:  Should not complain that it failed to save the
configuration.

Additional info:

Comment 1 Harald Hoyer 2004-05-24 10:38:40 UTC

*** This bug has been marked as a duplicate of 98252 ***

Comment 2 Pavel Tsekov 2004-05-24 13:24:03 UTC
Oops! Sorry for the duplicate report - I searched the bugzilla database
but only for issues related for Fedora Core and test 3.

Comment 3 Red Hat Bugzilla 2006-02-21 19:03:21 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.