Bug 98252 - No such file or directory: '//etc/sysconfig/network-scripts//ifcfg-lo.rpmsave'
Summary: No such file or directory: '//etc/sysconfig/network-scripts//ifcfg-lo.rpmsave'
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-network   
(Show other bugs)
Version: 2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
: 105780 108409 110031 112368 123716 123864 (view as bug list)
Depends On:
Blocks: rcn-profiling
TreeView+ depends on / blocked
 
Reported: 2003-06-29 06:07 UTC by Barry K. Nathan
Modified: 2007-11-30 22:10 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-20 09:24:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Barry K. Nathan 2003-06-29 06:07:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030619

Description of problem:
Whenever I attempt to save my configuration, I get an error message dialog box.

The title of the dialog box is "Warning", and it has a picture of an exclamation
point in a yellow triangle.

The text inside this dialog box is:
---begin quote---
redhat-config-network:

Error saving Configuration!
[Errno 2] No such file or directory:
'//etc/sysconfig/network-scripts//ifcfg-lo.rpmsave'
---end quote---

The configuration seems to get saved anyway.

Version-Release number of selected component (if applicable):
redhat-config-network-1.3.1-1
initscripts-7.25-1
rpm-4.2.1-0.11

How reproducible:
Always

Steps to Reproduce:
1. Make some kind of configuration change, or trick r-c-n into thinking you made
a change even when you didn't. (For example, double-click a PPP connection in
the Devices tab, then click OK.)

2. Choose Save from the File menu.

3. Quit r-c-n.

4. Start r-c-n up again and, if you made configuration changes, verify that they
took effect.

Actual Results:  Error message is displayed, but configuration is saved
nonetheless (as far as I can tell).

Expected Results:  Configuration saved without this error message.

Additional info:

[barryn@i5000e barryn]$ ls -l /etc/sysconfig/network-scripts/ifcfg-lo.rpmsave
lrwxrwxrwx    1 root     root           22 Jun 21 19:43
/etc/sysconfig/network-scripts/ifcfg-lo.rpmsave -> ../networking/ifcfg-lo
[barryn@i5000e barryn]$ ls -l /etc/sysconfig/networking/ifcfg-lo
ls: /etc/sysconfig/networking/ifcfg-lo: No such file or directory
[barryn@i5000e barryn]$ ls -l /etc/sysconfig/network-scripts/ifcfg-*
-rw-r--r--    3 root     root           74 Jun 28 22:49
/etc/sysconfig/network-scripts/ifcfg-eth0
-rw-r--r--    1 root     root          254 Jun 20  2001
/etc/sysconfig/network-scripts/ifcfg-lo
lrwxrwxrwx    1 root     root           22 Jun 21 19:43
/etc/sysconfig/network-scripts/ifcfg-lo.rpmsave -> ../networking/ifcfg-lo
-rw-r--r--    3 root     root          396 Jun 28 22:49
/etc/sysconfig/network-scripts/ifcfg-UCI_lifeline
[barryn@i5000e barryn]$ rpm -qf /etc/sysconfig/network-scripts/ifcfg-lo
initscripts-7.25-1

Hmmm... My best guess is that rpm left us with a dangling symlink when it
upgraded initscripts, and now redhat-network-config is choking. Perhaps r-c-n
isn't the guilty party, but it's the one displaying the message so for now
that's the component I'm reporting this bug against.

Comment 1 Harald Hoyer 2003-07-30 13:09:31 UTC
also with the latest rawhide version?

Comment 2 Harald Hoyer 2003-10-30 14:27:07 UTC
*** Bug 105780 has been marked as a duplicate of this bug. ***

Comment 3 Harald Hoyer 2003-10-30 14:27:26 UTC
*** Bug 108409 has been marked as a duplicate of this bug. ***

Comment 4 Barry K. Nathan 2004-03-07 03:05:58 UTC
(Sorry I took so long to respond)

Bug still happens with the Fedora Core 1 release. I'll need to retest
with FC-devel when I get a chance.

Comment 5 Harald Hoyer 2004-05-24 10:38:16 UTC
*** Bug 110031 has been marked as a duplicate of this bug. ***

Comment 6 Harald Hoyer 2004-05-24 10:38:26 UTC
*** Bug 112368 has been marked as a duplicate of this bug. ***

Comment 7 Harald Hoyer 2004-05-24 10:38:42 UTC
*** Bug 123716 has been marked as a duplicate of this bug. ***

Comment 8 Harald Hoyer 2004-05-24 10:38:47 UTC
*** Bug 123864 has been marked as a duplicate of this bug. ***

Comment 9 Keunwoo Lee 2004-07-19 19:35:42 UTC
*** Bug 128182 has been marked as a duplicate of this bug. ***

Comment 10 Harald Hoyer 2004-07-20 09:24:25 UTC
last duplication isn't a dup


Note You need to log in before you can comment on or make changes to this bug.