Bug 123800 - Left-Handed Mouse does not work when upgrading to FC2
Left-Handed Mouse does not work when upgrading to FC2
Status: CLOSED DUPLICATE of bug 121490
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Depends On:
  Show dependency treegraph
Reported: 2004-05-20 13:01 EDT by Rodney Thomas
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:03:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rodney Thomas 2004-05-20 13:01:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4)
Gecko/20030624 Netscape/7.1 (ax)

Description of problem:
I have upgraded two machines to FC2.  One was a desktop installed with
RedHat Linux 9 (free version).  The other was a laptop with FC1.  Both
machines previously had the mouse configured as left-handed.  After
upgrading both machines, and trying the GNOME and KDE GUI's, it
appeared that the entire GUI was messed up in relation to how the
mouse buttons worked.  It is as if the GUI's thought that both buttons
were the secondary mouse buttons; if I tried to do anything, the
buttons did not work properly.  With GNOME, I never successfully got
the left-handed option to work.  Switching to right-handed mouse
worked fine.  With KDE, switching to right-handed (which worked) and
back to left-handed appeared to get everything working except the
bottom, standard tool panel (with the red fedora), which still had the
button functions all confused.  I installed FC2 on a third machine
(desktop) as a clean install, non-upgrade, and after installing,
configured the system for a left-handed mouse; in this instance, the
left-handed mouse configuration worked fine.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Have either RH9 or FC1 installed on a machine.
2.Mouse configured as left-handed.
3.Upgraded with FC2.

Actual Results:  Left-handed mouse configuration does not work properly.

Expected Results:  Left-handed mouse configuration should work.

Additional info:
Comment 1 John Florian 2004-05-22 12:47:34 EDT
I too was bitten by this bug after upgrading a desktop with FC1
configured for left-handed mouse.  I was able to get FC2 and GNOME to
behave by editing /etc/X11/XF86Config.  I noticed that I had two
InputDevice sections for a mouse.  I commented out the section for
Mouse1 (keeping Mouse0).  I also had to comment out a reference to
Mouse1 in the ServerLayout section as follows:

Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        #InputDevice    "Mouse1" "SendCoreEvents"
        InputDevice    "Keyboard0" "CoreKeyboard"

Now I wonder if SendCoreEvents needs to be somehow associated with Mouse0.
Comment 2 Todd Kaehler 2004-05-25 11:04:01 EDT
I also have the same problem (upgraded from core 1).  I checked my
/etc/X11/XF86Config and I only have Mouse0 defined so the above edits
are not possible...
Comment 3 Mark McLoughlin 2004-08-06 14:38:55 EDT

*** This bug has been marked as a duplicate of 121490 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:03:22 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.