Bug 1238052 - Quota list is not working on tiered volume.
Summary: Quota list is not working on tiered volume.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.7.2
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact: bugs@gluster.org
URL:
Whiteboard: Tiering
Depends On: 1230540 1236128 1254439
Blocks: 1229259 1260923
TreeView+ depends on / blocked
 
Reported: 2015-07-01 05:47 UTC by Mohammed Rafi KC
Modified: 2015-10-30 17:32 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1236128
Environment:
Last Closed: 2015-07-30 09:51:57 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-07-01 05:49:10 UTC
REVIEW: http://review.gluster.org/11475 (tiering/quota: failed to match subvolume) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Anand Avati 2015-07-01 15:02:32 UTC
COMMIT: http://review.gluster.org/11475 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 8e4cc51e36514db9bf1ca2beac993091c95c649a
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Tue Jun 30 11:15:54 2015 +0530

    tiering/quota: failed to match subvolume
    
    quota daemon choose subvolume for a volume using
    volume-id specified in graph. For that it expect
    a subvolume (DHT) to be named as volume-id. But
    tiering translator comes above dht, so it failed to
    match the correct subvolume.
    
    >Change-Id: I63d4b63cd8fb2806bc7b2b2f100dbef62202e6da
    >BUG: 1236128
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/11431
    >Reviewed-by: Joseph Fernandes
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    >Tested-by: Dan Lambright <dlambrig@redhat.com>
    
    (cherry picked from commit e9807b8e5799cd5f62fcaa1f228bb470f4bc1157)
    
    Change-Id: I2a2230e3f9172c08cef993854a3a8ac6eb7271c4
    BUG: 1238052
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/11475
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>

Comment 3 Kaushal 2015-07-30 09:51:57 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.