Bug 1254439 - Quota list is not working on tiered volume.
Quota list is not working on tiered volume.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.3
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Mohammed Rafi KC
bugs@gluster.org
Tiering
: Triaged
Depends On: 1230540 1236128
Blocks: 1229259 1238052 1260923
  Show dependency treegraph
 
Reported: 2015-08-18 03:19 EDT by Mohammed Rafi KC
Modified: 2015-10-30 13:32 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1236128
Environment:
Last Closed: 2015-09-09 05:39:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2015-08-19 04:38:38 EDT
COMMIT: http://review.gluster.org/11947 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit d703745493e7cf5eec41875dc5c786d29ef2de03
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Tue Jun 30 11:22:31 2015 +0530

    ctr:Avoid assertion failure in lookup
    
    in ctr_lookup, the loc variable need not be comes with pargfid,
    though there is a parent for the inode. The same for loc->name
    also. From this patch, we will generate loc->name from loc->path
    
    Back port of :
    
    >Change-Id: I24a79554748139504ec09f77930f8208d3805977
    >BUG: 1236128
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/11459
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Joseph Fernandes
    
    (cherry picked from commit 2e44d1580497eb75f325ad3104249a425ddf592a)
    
    Change-Id: Ia926bee45059ec97bbe5120f19999b9d5a71aa88
    BUG: 1254439
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/11947
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 2 Kaushal 2015-09-09 05:39:53 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.