Bug 1238072 - protocol/server doesn't reconfigure auth.ssl-allow options
Summary: protocol/server doesn't reconfigure auth.ssl-allow options
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: protocol
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kaushal
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1228127 1238073 1238074
TreeView+ depends on / blocked
 
Reported: 2015-07-01 07:01 UTC by Kaushal
Modified: 2016-06-16 13:18 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1238073 1238074 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:18:34 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kaushal 2015-07-01 07:01:58 UTC
The auth.ssl-allow option isn't being handled by the protol/server xlator. This is causing even simple addition and deletions from the ssl-allow option to require a restart of the volume to be applied.

Comment 1 Anand Avati 2015-07-01 07:04:27 UTC
REVIEW: http://review.gluster.org/11487 (protocol/server: Correctly reconfigure auth.ssl-allow) posted (#1) for review on master by Kaushal M (kaushal@redhat.com)

Comment 2 Nagaprasad Sathyanarayana 2015-10-25 15:07:23 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 3 Niels de Vos 2016-06-16 13:18:34 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.