Bug 1238073 - protocol/server doesn't reconfigure auth.ssl-allow options
Summary: protocol/server doesn't reconfigure auth.ssl-allow options
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: protocol
Version: 3.7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kaushal
QA Contact:
URL:
Whiteboard:
Depends On: 1238072
Blocks: glusterfs-3.7.3
TreeView+ depends on / blocked
 
Reported: 2015-07-01 07:03 UTC by Kaushal
Modified: 2015-07-30 09:50 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1238072
Environment:
Last Closed: 2015-07-30 09:50:36 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kaushal 2015-07-01 07:03:48 UTC
+++ This bug was initially created as a clone of Bug #1238072 +++

The auth.ssl-allow option isn't being handled by the protol/server xlator. This is causing even simple addition and deletions from the ssl-allow option to require a restart of the volume to be applied.

Comment 1 Anand Avati 2015-07-01 12:40:05 UTC
REVIEW: http://review.gluster.org/11492 (protocol/server: Correctly reconfigure auth.ssl-allow) posted (#1) for review on release-3.7 by Kaushal M (kaushal@redhat.com)

Comment 2 Anand Avati 2015-07-06 02:57:59 UTC
REVIEW: http://review.gluster.org/11492 (protocol/server: Correctly reconfigure auth.ssl-allow) posted (#2) for review on release-3.7 by Kaushal M (kaushal@redhat.com)

Comment 3 Anand Avati 2015-07-06 07:14:24 UTC
COMMIT: http://review.gluster.org/11492 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit d8fed39922e54d7abe45963090f9f621262b086d
Author: Kaushal M <kaushal@redhat.com>
Date:   Wed Jul 1 11:44:53 2015 +0530

    protocol/server: Correctly reconfigure auth.ssl-allow
    
      Backport of https://review.gluster.org/11487
    
    auth.ssl-allow wasn't being handled during reconfigure. This prevented
    the ssl-allow list from being live reloaded.
    
    Change-Id: If3435793a5684881b012de77cb254b1847b37810
    BUG: 1238073
    Signed-off-by: Kaushal M <kaushal@redhat.com>
    Reviewed-on: http://review.gluster.org/11492
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>

Comment 4 Kaushal 2015-07-30 09:50:36 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.