Bug 123823 - gnome-volume-control does not indicate correct mute status
gnome-volume-control does not indicate correct mute status
Status: CLOSED DUPLICATE of bug 106138
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
2
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-20 14:57 EDT by Michael Elkins
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Elkins 2004-05-20 14:57:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
The mute checkbox in gnome-volume-control toggles the volume between
the current setting and zero.  However, ALSA has a separate mute
function that is independent of the volume level.  Upon intallation,
ALSA defaults to mute status on all outputs, and you need to use
alsamixer to unmute the outputs, because gnome-volume-control does not
clear the mute status.  Toggling the mute checkbox in
gnome-volume-control therefore has no effect until you use alsamixer
to unmute all output sources.

Version-Release number of selected component (if applicable):
gnome-media-2.6.0-1

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora and configure sound
2. open gnome-volume-control and switch to the ALSA mixer tab
3. Note that none of the mute checkboxes are selected
4. Attempt to play a sound, and it will not be audible.
5. Open gnome-terminal and run alsamixer, note that input sources are
all muted (with the MM indicator at the top of each "slider")
6.  Use alsamixer to unmute the input/output sources.
7.  Sound will now work.

    

Actual Results:  gnome-volume-control will have no effect until you
use alsamixer to unmute the input/output sources.

Expected Results:  gnome-volume-control's mute function for
input/output sources should use the ALSA mute function instead of
controlling the volume level for each source.

Additional info:
Comment 1 petrosyan 2004-06-17 07:51:18 EDT
this is a duplicate of bug #106138
Comment 2 Colin Walters 2004-09-21 23:03:57 EDT
Thanks Anl.

*** This bug has been marked as a duplicate of 106138 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:03:23 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.