Bug 106138 - Muting the volume control applet doesn't change icon
Summary: Muting the volume control applet doesn't change icon
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-artwork (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: Triaged
: 110705 111627 113784 123688 123823 (view as bug list)
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-10-03 02:41 UTC by Marc Deslauriers
Modified: 2007-11-30 22:10 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-19 10:03:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marc Deslauriers 2003-10-03 02:41:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20030926

Description of problem:
The volume control applet doesn't get crossed-out with a red line when it is
muted like it did in Red Hat Linux 9, for example.

Version-Release number of selected component (if applicable):
gnome-applets-2.3.7-1

How reproducible:
Always

Steps to Reproduce:
1.Right click on the volume control applet
2.Click on "mute"
3.Icon didn't change
    

Actual Results:  The icon didn't change

Expected Results:  I expect the icon to reflect the "mute" status

Additional info:

Comment 1 Havoc Pennington 2003-10-08 21:59:31 UTC
Maybe just an icon theme problem?

Comment 2 Michael Lee Yohe 2003-11-04 17:30:24 UTC
It still doesn't happen with the newer Rawhide applets package.  Does
it fetch an icon from another package?

$ rpm -q gnome-applets
gnome-applets-2.4.1-1


Comment 3 Carlos Rodrigues 2003-11-22 00:22:30 UTC
This also happens with Fedora Core 1.

Comment 4 Aleksey Nogin 2004-01-07 05:11:56 UTC
*** Bug 110705 has been marked as a duplicate of this bug. ***

Comment 5 Aleksey Nogin 2004-01-07 05:22:57 UTC
*** Bug 111627 has been marked as a duplicate of this bug. ***

Comment 6 Aleksey Nogin 2004-01-19 05:23:00 UTC
*** Bug 113784 has been marked as a duplicate of this bug. ***

Comment 7 Bart Martens 2004-03-03 23:26:56 UTC
The problem is caused by the fact that in redhat-artwork the "mute"
icons are identical to the "zero" icons (symlink). The "mute" icons
are supposed to be icons to be drawn over a base icon. See
gnome-applets-2.4.1/mixer/mixer.c:562 where the base icon and the
"mute" icon are combined with gdk_pixbuf_composite. When
volume-max.png and volume-mute.png (=volume-zero.png) are combined
when the volume is muted, the visual effect is that the icon does not
change. The solution is to add "mute" icons in redhat-artwork similar
to /usr/share/pixmaps/mixer/volume-mute.png .

ls -l /usr/share/icons/Bluecurve/*/stock/volume-mute.png
redhat-artwork-0.88-1

Changing component to redhat-artwork.
Changing version to 1.


Comment 8 Marc Deslauriers 2004-05-02 14:34:50 UTC
This is still happening with redhat-artwork-0.9.6-1 from Fedora Core 2
Test 3.


Comment 9 Vibol Hou 2004-05-08 20:15:57 UTC
I am experiencing this also, but someone on the fedora-test list
mentioned that their applet is working properly (i.e. red slash across
applet icon)

Comment 10 Vibol Hou 2004-05-08 20:17:56 UTC
Forgot to mention FC2T3:

redhat-artwork-0.96-1
gnome-applets-2.6.0-4

Comment 11 Matt Hansen 2004-05-09 01:48:32 UTC
In reply to comment #9 above, it will work correctly (i.e. will change
to a crossed-out icon) while using a different icon theme. It's a
Bluecurve issue as described in comment #7. 
Will this be fixed for FC2 final or an update?

Comment 12 Carlos Rodrigues 2004-07-09 18:43:37 UTC
Not fixed in FC2.

Comment 13 Colin Walters 2004-09-22 03:03:11 UTC
*** Bug 123688 has been marked as a duplicate of this bug. ***

Comment 14 Colin Walters 2004-09-22 03:04:01 UTC
*** Bug 123823 has been marked as a duplicate of this bug. ***

Comment 15 Alexander Larsson 2004-10-06 08:09:40 UTC
Hmmm. It seems the recent version of the mixer applet doesn't even use
the Bluecurve themed icons.

Comment 16 Alexander Larsson 2004-10-06 08:20:05 UTC
I filed https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=134773
about not using the bluecurve icons, and i removed the volume-muted
icon from redhat-artwork cvs. It'll be in the next build of it.

Comment 17 petrosyan 2004-10-16 15:23:27 UTC
this bug has been fixed in Fedora Core development


Note You need to log in before you can comment on or make changes to this bug.