This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 123853 - kdelibs-devel should require libselinux-devel
kdelibs-devel should require libselinux-devel
Status: CLOSED DUPLICATE of bug 123666
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-20 19:01 EDT by Ville Skyttä
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-02 02:26:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2004-05-20 19:01:44 EDT
kdelibs-3.2.2-6 is missing a dependency on libselinux-devel:

$ grep selinux /usr/lib/libkparts.la
dependency_libs=' -L/usr/kerberos/lib /usr/lib/libkio.la
-L/usr/X11R6/lib -L/usr/lib/qt-3.3/lib -L/usr/lib /usr/lib/libkdeui.la
/usr/lib/libkdesu.la /usr/lib/libkdecore.la /usr/lib/libDCOP.la -ldl
-lresolv -lart_lgpl_2 /usr/lib/libkdefx.la -lqt-mt -lpng -lXext -lX11
-lSM -lICE -lpthread -lXrender -lutil -lz /usr/lib/libfam.la -lselinux'

Without this dependency it becomes a PITA to create spec files for
kparts apps that should work in eg. FC1 and FC2.
Comment 1 Mary Ellen Foster 2004-05-21 04:59:59 EDT
It's also the case that, e.g., the kdemultimedia SRPM doesn't 
specify BuildRequires libselinux-devel, but fails to build without 
it being installed (as I discovered last night). I assume this is 
related. 
Comment 2 Ville Skyttä 2004-05-28 14:03:54 EDT
Actually the root cause seems to be in fam-devel.

*** This bug has been marked as a duplicate of 123666 ***

Note You need to log in before you can comment on or make changes to this bug.