Bug 123666 - fam-devel must requires libselinux-devel.
fam-devel must requires libselinux-devel.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fam (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
: EasyFix, SELinux
: 123853 124197 (view as bug list)
Depends On:
Blocks: FC2Update
  Show dependency treegraph
 
Reported: 2004-05-19 17:35 EDT by Dams
Modified: 2007-11-30 17:10 EST (History)
10 users (show)

See Also:
Fixed In Version: 2.6.10-9.FC2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-19 15:04:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dams 2004-05-19 17:35:13 EDT
Description of problem:
[root@gruyere ~]# rpm -q fam-devel -R
fam = 2.6.10-9
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
[root@gruyere ~]# ldd /usr/lib/libfam.so|grep selinux
        libselinux.so.1 => /lib/libselinux.so.1 (0x00990000)
[root@gruyere ~]#

fam-devel actually doesnt requires libselinux-devel on Fedora Core 2
but it just must ! When trying to rebuild some fam dependent packages,
some linking errors can occurs if libselinux-devel isnt installed.

Version-Release number of selected component: fam-2.6.10-9
Comment 1 Ville Skyttä 2004-05-28 14:02:40 EDT
I see than's 2.6.10-10 in rawhide fixes this.  Please issue an FC2
errata as this bug propagates to other packages, and is a PITA for
everybody building for example any KDE packages.  For example many
fedora.us packages depend on this fix.

(I tried to add SELinux and EasyFix keywords, but Bugzilla wouldn't
let me do it.)
Comment 2 Ville Skyttä 2004-05-28 14:03:56 EDT
*** Bug 123853 has been marked as a duplicate of this bug. ***
Comment 4 Warren Togami 2004-06-10 00:08:59 EDT
http://people.redhat.com/wtogami/temp/fam/
Please verify that these update candidate binaries do not introduce
any regressions on both i386 and x86_64.  Theoretically nothing
changed except buildrequires, but it is always best to test...
 
Comment 5 Michael Schwendt 2004-06-18 20:38:54 EDT
Assumably, libselinux-devel is an implicit BR in Red Hat's build
system. Else this package would fail to build (see included *selinux*
patch).

So, the only real change I see is "Requires: libselinux-devel" in the
fam-devel package, and that is the expected fix for this bug. 

Your binary candidates do not differ from the stock FC2 packages with
regard to size of included files and output of "rpm -qR" (except for
the added libselinux-devel).

[Didn't get comment 4 by mail, so sorry if I'm late.]
Comment 6 Ville Skyttä 2004-06-19 04:10:00 EDT
Comment 4 didn't trigger a mail for me either, comment 5 did.  I've
installed the i386 candidate now.
Comment 7 Justin M. Forbes 2004-06-21 11:52:09 EDT
This is something that needs to be addressed on a larger scale, and
something that I ran across when doing the last k3b builds. 
libselinux-devel is an implied BuildRequres on many packages now, RPM
seems to enforce this.  The problem becomes visible when doing builds
in a chroot environment (mach).  Would the right solution be to make
libselinux-devel a Requires for RPM or explicitly add libselinux-devel
as a build requires for every package?  I am guessing the rpm Requires
is the better solution.
Comment 8 Ville Skyttä 2004-06-21 13:05:25 EDT
AFAICS, neither suggestion is correct in comment 7.  Only packages
really directly requiring $whatever should have the dependency.

Having rpm require libselinux-devel is clearly wrong, ditto for
rpmbuild.  Neither do require it, so they do not and should not depend
on it.

Practically all KDE related packages require fam-devel (implicitly
through kdelibs-devel), and practially all of them have nothing to do
with libselinux or -devel.  Polluting them with the build dependency
on libselinux-devel does not make sense.

On the other hand, fam-devel directly requires libselinux-devel (see
/usr/lib/libfam.la (dependency_libs)).  That should be fixed.

Yet on the other hand, rpm-devel could (and should) depend on
libselinux-devel (as well as a whole slew of others, see
/usr/lib/librpm.la); that would mask the problem with mach, but AFAICS
only because the default mach configs install rpm-devel to the build
roots (which I think is a mach bug, I don't know why rpm-devel should
be "assumed present" in build roots).
Comment 9 Ville Skyttä 2004-06-29 18:16:13 EDT
I've been using the (i386) packages from comment 4 for some time now
without any problems.  Please update...
Comment 10 Ville Skyttä 2004-06-29 18:16:39 EDT
*** Bug 124197 has been marked as a duplicate of this bug. ***
Comment 11 Ville Skyttä 2004-07-19 15:04:43 EDT
Thanks!
Comment 12 D. Hugh Redelmeier 2004-08-30 02:36:09 EDT
I don't think that this is fixed in errata.  It is still causing me
problems.  "rpm -Fv i386/fam-devel-2.6.10-9.FC2.i386.rpm" won't work.
 Here's why:
  $ rpm -qp --requires i386/fam-devel-2.6.10-9.FC2.i386.rpm
  fam = 2.6.10-9.FC2
  libselinux-devel
  rpmlib(CompressedFileNames) <= 3.0.4-1
  rpmlib(PayloadFilesHavePrefix) <= 4.0-1

  $ rpm -qp --requires x86_64/fam-devel-2.6.10-9.FC2.x86_64.rpm
  fam = 2.6.10-9.FC2
  libselinux-devel
  rpmlib(CompressedFileNames) <= 3.0.4-1
  rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Comment 13 Daniel Veillard 2004-08-30 03:41:36 EDT
fam/fam-devel can't be fixed for SELinux in Fedora [1]. fam/fam-devel
are deprecated by gamin (/gamin-devel) available in Fedora Core 
development. The gamin packages Provides and Obsolete fam, 
   http://www.gnome.org/~veillard/gamin/

Daniel

[1] the central system wide daemon model fam is based upon is really
    not compatible with SELinux.
Comment 14 Michael Schwendt 2004-08-30 07:08:08 EDT
Re: comment 12 -> exactly that was the fix. You're correct in that you
cannot use "rpm -Fv" to install the update package. You need "rpm -Uv
--aid" to pull in libselinux-devel, which was added to fix this bug.
Note that this bug fix was just done to complete the dependencies of
the fam-devel package.

Note You need to log in before you can comment on or make changes to this bug.