Bug 1238608 - Repeating georep config options
Summary: Repeating georep config options
Keywords:
Status: CLOSED DUPLICATE of bug 1005344
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Saravanakumar
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-02 09:21 UTC by Saravanakumar
Modified: 2015-09-09 09:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-09 09:57:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Saravanakumar 2015-07-02 09:21:48 UTC
Description of problem:

gluster volume get <volname> all 
Displays geo-replication options twice

Version-Release number of selected component (if applicable):


How reproducible:
Create a volume

Run the command, gluster volume get <volname> all 



Steps to Reproduce:
1. Create volume
2. gluster volume get <volname> all | grep geo-replication
3. You should notice georep options twice.

Actual results:
georep options repeated twice.

Expected results:
georep options should be displayed once.


Additional info:

Comment 1 Anand Avati 2015-07-02 09:23:08 UTC
REVIEW: http://review.gluster.org/11505 (geo-rep: Avoid repeating georep config options) posted (#2) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)

Comment 2 Anand Avati 2015-07-02 09:26:30 UTC
REVIEW: http://review.gluster.org/11505 (geo-rep: Avoid repeating georep config options) posted (#3) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)

Comment 3 Atin Mukherjee 2015-07-03 06:10:17 UTC
http://review.gluster.org/10262 has the fix for it. However this patch fixes the other duplication options as well. I would recommend you to take a look at it.

Comment 4 Saravanakumar 2015-09-09 09:57:10 UTC

*** This bug has been marked as a duplicate of bug 1005344 ***


Note You need to log in before you can comment on or make changes to this bug.