Bug 1238668 - Failed to pass stage of storage domain name
Summary: Failed to pass stage of storage domain name
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.5.4
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Sandro Bonazzola
QA Contact: Artyom
URL:
Whiteboard:
: 1238667 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-02 11:25 UTC by Artyom
Modified: 2016-03-09 19:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1238691 (view as bug list)
Environment:
Last Closed: 2016-03-09 19:13:04 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0375 normal SHIPPED_LIVE ovirt-hosted-engine-setup bug fix and enhancement update 2016-03-09 23:48:34 UTC
oVirt gerrit 43147 ovirt-hosted-engine-setup-1.2 MERGED pakaging: setup: add return value to function _validName Never

Description Artyom 2015-07-02 11:25:10 UTC
Description of problem:
Run hosted-engine --deploy on NFS storage, continue until you need to enter storage domain name, stage stuck no matter what input you give.
Please provide storage domain name. [hosted_storage]: 
          Storage domain name cannot be empty. It can only consist of alphanumeric characters (that is, letters, numbers, and signs "-" and "_"). All other characters are not valid in the name.
          Please provide storage domain name. [hosted_storage]: hosted_storage
          Storage domain name cannot be empty. It can only consist of alphanumeric characters (that is, letters, numbers, and signs "-" and "_"). All other characters are not valid in the name.

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.2.5-1.el7ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. See above
2.
3.

Actual results:
Deployment can not pass stage of storage domain name

Expected results:
Deployment must pass stage of storage domain name if name is correct and continue deployment

Additional info:

Comment 1 Sandro Bonazzola 2015-07-02 11:57:28 UTC
According to Artyom the bug affects 3.5.4 only, 3.6 is safe. So marking this as testonly for 3.6.

Comment 3 Artyom 2015-07-02 12:40:34 UTC
Verified on ovirt-hosted-engine-setup-1.3.0-0.0.master.20150623153111.git68138d4.el7.noarch

Comment 4 Sandro Bonazzola 2015-07-03 07:40:33 UTC
*** Bug 1238667 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2016-03-09 19:13:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0375.html


Note You need to log in before you can comment on or make changes to this bug.