Bug 1238747 - Crash in Quota enforcer
Summary: Crash in Quota enforcer
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vijaikumar Mallikarjuna
QA Contact:
URL:
Whiteboard:
Depends On: 1238047 1238048 1238049
Blocks: 1242898
TreeView+ depends on / blocked
 
Reported: 2015-07-02 14:06 UTC by Vijaikumar Mallikarjuna
Modified: 2016-06-16 13:19 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1238049
: 1242898 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:19:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-07-02 14:08:01 UTC
REVIEW: http://review.gluster.org/11510 (quota: Fix crash in quota enforcer) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Anand Avati 2015-07-03 09:38:50 UTC
REVIEW: http://review.gluster.org/11510 (quota: Fix crash in quota enforcer) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Anand Avati 2015-07-07 11:31:55 UTC
REVIEW: http://review.gluster.org/11510 (quota: Fix crash in quota enforcer) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 4 Anand Avati 2015-07-07 14:23:38 UTC
REVIEW: http://review.gluster.org/11510 (quota: Fix crash in quota enforcer) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 5 Anand Avati 2015-07-08 08:47:37 UTC
REVIEW: http://review.gluster.org/11510 (quota: Fix crash in quota enforcer) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 6 Anand Avati 2015-07-09 03:11:17 UTC
REVIEW: http://review.gluster.org/11510 (quota: Fix crash in quota enforcer) posted (#6) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 7 Anand Avati 2015-07-10 08:35:11 UTC
REVIEW: http://review.gluster.org/11510 (quota: Fix crash in quota enforcer) posted (#7) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 8 Anand Avati 2015-07-11 04:08:32 UTC
REVIEW: http://review.gluster.org/11510 (quota: Fix crash in quota enforcer) posted (#9) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 9 Anand Avati 2015-07-13 09:04:05 UTC
REVIEW: http://review.gluster.org/11510 (quota: Fix crash in quota enforcer) posted (#10) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 10 Anand Avati 2015-07-13 15:22:55 UTC
REVIEW: http://review.gluster.org/11510 (quota: Fix crash in quota enforcer) posted (#11) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 11 Anand Avati 2015-07-14 11:04:15 UTC
COMMIT: http://review.gluster.org/11510 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 84ecb016cd2f1c8853c22e2df7d44d6c7bf32ed7
Author: vmallika <vmallika@redhat.com>
Date:   Tue Jul 7 16:56:12 2015 +0530

    quota: Fix crash in quota enforcer
    
    With multiple hardlinks check_quota_limit is invoked for each parent
    each of this check_limit can invoke validation
    this can cause frame->local to get corrupted during validation.
    
    Testcase tests/bugs/quota/bug-1235182.t fails spuriously with
    this problem
    
    Change-Id: I53adc54b431fb5f43e67a94248102ddaf0d7978f
    BUG: 1238747
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/11510
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 12 Nagaprasad Sathyanarayana 2015-10-25 15:08:06 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 13 Niels de Vos 2016-06-16 13:19:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.