Bug 1242898 - Crash in Quota enforcer
Summary: Crash in Quota enforcer
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: 3.7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vijaikumar Mallikarjuna
QA Contact:
URL:
Whiteboard:
Depends On: 1238047 1238048 1238049 1238747
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-14 11:06 UTC by Vijaikumar Mallikarjuna
Modified: 2016-05-11 22:48 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1238747
Environment:
Last Closed: 2015-07-30 09:50:51 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-07-14 11:13:43 UTC
REVIEW: http://review.gluster.org/11662 (quota: Fix crash in quota enforcer) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Anand Avati 2015-07-16 10:41:32 UTC
REVIEW: http://review.gluster.org/11662 (quota: Fix crash in quota enforcer) posted (#2) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Anand Avati 2015-07-21 10:20:27 UTC
COMMIT: http://review.gluster.org/11662 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit cb8f419fd8e36b6eb5a48db5694e475cb79553c9
Author: vmallika <vmallika@redhat.com>
Date:   Tue Jul 7 16:56:12 2015 +0530

    quota: Fix crash in quota enforcer
    
    This is a backport of http://review.gluster.org/11510
    
    With multiple hardlinks check_quota_limit is invoked for each parent
    each of this check_limit can invoke validation
    this can cause frame->local to get corrupted during validation.
    
    Testcase tests/bugs/quota/bug-1235182.t fails spuriously with
    this problem
    
    > Change-Id: I53adc54b431fb5f43e67a94248102ddaf0d7978f
    > BUG: 1238747
    > Signed-off-by: vmallika <vmallika@redhat.com>
    > Reviewed-on: http://review.gluster.org/11510
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    
    Change-Id: Ia7f57276db034e0fc6cd84dbf618ce0d4fae4321
    BUG: 1242898
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/11662
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 4 Kaushal 2015-07-30 09:50:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.