This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 123893 - Error activating XKB configuration. Probably internal X server problem.
Error activating XKB configuration. Probably internal X server problem.
Status: CLOSED DUPLICATE of bug 120858
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-21 09:21 EDT by Michael Weske
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Weske 2004-05-21 09:21:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.6) Gecko/20040510

Description of problem:
installed Fedora Core 2.  ran yum -y update (21.May04 07:30 Eastern).

On boot this error appears: (everything appears to be working!!)
Error activating XKB configuration.
Probably internal X server problem.
                                                                     
          
X server version data:
The X.Org Foundation
60700000
                                                                     
          
If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
---------
here is the requested info:
#  xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us", "", ""
#
                                                                     
          
                                                                     
          # gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [us]
 model = pc105
 overrideSettings = false
 options = []
#


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. restart system
2.
3.
    

Actual Results:  get window with error message.  Click "OK" everything
seems to be runnign fine.

Expected Results:  don't get error message

Additional info:
Comment 1 John MacLean 2004-05-22 11:25:35 EDT
I get the same messages. Select Close and it comes back. Selecting
Close again gets rid of the message.

Same output from xprop and gconftool. 

When I try changing the keyboard model (doesn't matter which one I
select), the error will reappear immediately.

The keyboard, however, is functional.

Comment 2 Hrunting Johnson 2004-05-22 11:40:13 EDT
Take a look at bug 122454.  It has more information and links to other
bugs that have fixes.  Looks like you need to remove the line 'option
Xkbrules "xfree86"' from your XF86Config file.
Comment 3 Richard 2004-05-22 16:54:46 EDT
FYI, I had the same issue on two very different home-grown PCs (one
motherboard is ASUS and the other ABIT) that had been upgraded from
FC1 to FC2.  When I applied the above suggestion to
/etc/X11/XF86Config, both PCs ceased showing that error popup.  Thanks.
Comment 4 Phil Schaffner 2004-05-25 17:27:54 EDT
Encountered this bug after FC1/FC2 upgrade on IBM A21p, manual
creation of xorg.conf from XF86Config after system-config-display
failed, and applying /dev/input/mice workaround for BZ 120859.  The
XKB popup error window appeared 9 times on first attempt to "startx"
into Gnome from runlevel 3.  No errors in KDE.  The removal of 'Option
"Xkbrules" "xfree86"' workaround made the errors go away.
Comment 5 Mike A. Harris 2004-05-25 18:16:39 EDT

*** This bug has been marked as a duplicate of 120858 ***
Comment 6 Omi Chandiramani 2004-09-29 15:08:34 EDT
I just installed FC2 on my machine and am having this problem. The
/etc/X11/xorg.conf does not contain the XKbrules "xfree86" line it. I
see the error only when I log in as a non root user. 

I'm up to date as far as yum is concerned. Here is the output
requested on the error screen: 

--
[root@localhost root]# xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "", ""
[root@localhost root]# gconftool-2 -R
/desktop/gnome/peripherals/keyboard/xkb  layouts = [us]
 model = pc105
 overrideSettings = false
 options = []
[root@localhost root]#
--

And here are the relevant uncommented lines from my xorg.conf: 

--
Section "InputDevice"
                                                                     
                  Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection
--

So what else could be causing this?
                                                                     
          


Comment 7 Mike A. Harris 2004-09-30 03:13:51 EDT
Bug #120858 is the master bug report tracking this issue.  Full
details of the problem(s) and their solutions are present in that
bug, or one of the other bugs marked as duplicates of it.

If you still have this problem after following the guidelines in
that bug report, you may wish to subscribe to the fedora-list
mailing list for assistance.

Comment 8 Red Hat Bugzilla 2006-02-21 14:03:25 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.