Bug 1238948 - [RFE] virt-who should be a capsule function
Summary: [RFE] virt-who should be a capsule function
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Subscription Management
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1262487 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-03 06:51 UTC by Fred van Zwieten
Modified: 2017-10-05 17:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-05 17:25:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 16202 0 None None None 2016-08-19 18:01:32 UTC

Description Fred van Zwieten 2015-07-03 06:51:48 UTC
Description of problem:
virt-who requires a RHEL system subscribed to satellite to be able to function. As I understand it this is because it uses subscription-manager (API) to communicate with satellite. I propose to change virt-who in a way that it is one of the optional features of a capsule (including the embedded capsule). It should be configurable using katello-installer and/or capsule-installer. It is part of the subscription-management part of satellite and as such should *just work*.

Version-Release number of selected component (if applicable):
6.1.0

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 RHEL Program Management 2015-07-03 07:05:27 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Bryan Kearney 2015-10-16 17:08:23 UTC
*** Bug 1262487 has been marked as a duplicate of this bug. ***

Comment 4 Zach Huntington-Meath 2016-08-19 17:06:45 UTC
Created redmine issue http://projects.theforeman.org/issues/16202 from this bug

Comment 5 Bryan Kearney 2017-10-05 17:25:33 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.