Bug 1239077 - Cannot rename product back to original name after importing a manifest
Summary: Cannot rename product back to original name after importing a manifest
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API
Version: 6.0.8
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Tom McKay
QA Contact: Katello QA List
URL:
Whiteboard:
: 1238638 (view as bug list)
Depends On:
Blocks: sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-07-03 12:40 UTC by Justin Sherrill
Modified: 2019-07-11 09:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-22 17:53:51 UTC


Attachments (Terms of Use)

Description Justin Sherrill 2015-07-03 12:40:55 UTC
Version-Release number of selected component (if applicable):
6.0.8 and 6.1.0


How reproducible:
always

Steps to Reproduce:
1.  Create a product named 'foo' in a new org
2.  Import a manifest 
3.  Rename the product to 'bar'
4.  Attempt to rename the product back to 'foo'

Actual results:
Error:

  Validation failed: Name Product with name 'foo' already exists in this organization.



Expected results:

product renames successfully.


Additional info:


A workaround would be to do this:

# foreman-rake console
> Katello::MarketingProduct.find_by_name('foo').destroy

and then rename again.  Notice that the problem may come back as soon as you import or refresh a manifest

Comment 2 Brad Buckingham 2015-07-07 17:21:53 UTC
*** Bug 1238638 has been marked as a duplicate of this bug. ***

Comment 5 David O'Brien 2016-04-18 00:47:57 UTC
Reset docs contact <> daobrien

Comment 7 Bryan Kearney 2018-03-22 17:53:51 UTC
The work around code no longer exists in the product, so I am assuming this is no longer an issue. I am closing this out as WONTFIX. If you are still seeing this issue please feel free to re-open with additional information.


Note You need to log in before you can comment on or make changes to this bug.