Bug 1239231 - Firefox always showing: Firefox is having trouble recovering your windows and tabs screen
Summary: Firefox always showing: Firefox is having trouble recovering your windows an...
Keywords:
Status: CLOSED DUPLICATE of bug 1240259
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 22
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-04 18:27 UTC by Gerald Cox
Modified: 2015-07-06 16:39 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-06 16:32:08 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 1180371 None None None Never

Description Gerald Cox 2015-07-04 18:27:55 UTC
Description of problem:  Upon startup, Firefox is always showing
the "Firefox is having trouble recovering your windows and tabs screen".


Version-Release number of selected component (if applicable):
firefox-39.0-6.fc22.x86_64


How reproducible:
Stop firefox and restart


Steps to Reproduce:
1.  See above
2.
3.

Actual results:
Display of "Firefox is having trouble recovering your windows and tabs screen"

Expected results:
Normal display.


Additional info:
This started occuring with the 39.0-6 upgrade.  Never encountered this issue before.  I've tried deleting the .mozilla directory and starting over, but doesn't help.  Problem still occurs, so appears something happened with the latest upgrade.

Comment 1 Cesar Eduardo Barros 2015-07-05 13:08:39 UTC
The corresponding Mozilla bug report seems to be https://bugzilla.mozilla.org/show_bug.cgi?id=1180371

Comment 2 Markus S. 2015-07-05 21:47:32 UTC
Works for me…

Comment 3 Martin Stransky 2015-07-06 06:08:13 UTC
Looks like there's a firefox crash when browser close so the session is not stored. Can you please launch firefox in gdb, quit firefox and see if it crashes in gdb? If so please attach a backtrace. How-to is here:  http://fedoraproject.org/wiki/Debugging_guidelines_for_Mozilla_products#Application_crash
Thanks.

Comment 4 Dario Castellarin 2015-07-06 10:11:32 UTC
Hi, I tried to debug the problem following the instructions you provided, but the only thing that gets written in crash_bt is "You can't do that without a process to debug.", just after I tried to print DumpJSStack(). gdb actually shows firefox exiting correctly so it appears there's no crash involved.

[Thread 0x7ffff7fd5740 (LWP 5625) exited]
[Inferior 1 (process 5625) exited normally]

Comment 5 Gerald Cox 2015-07-06 16:32:08 UTC

*** This bug has been marked as a duplicate of bug 1240259 ***


Note You need to log in before you can comment on or make changes to this bug.