Bug 1240259 - Firefox 39 does not open home page but "restore session"
Summary: Firefox 39 does not open home page but "restore session"
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1239231 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-06 11:29 UTC by Didier G
Modified: 2015-07-25 14:22 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-09 09:04:03 UTC
Type: Bug


Attachments (Terms of Use)

Description Didier G 2015-07-06 11:29:48 UTC
Description of problem:

Firefox 39 not open home page defined in Preferences but "restore session"


Version-Release number of selected component (if applicable):

firefox-39.0-6.fc22.x86_64


How reproducible:
Steps to Reproduce:

1. update to firefox-39.0-6.fc22.x86_64
2. start firefox
3. define home page in Preferences
4. properly close Firefox
5. restart Firefox


Actual results:

Firefox display "restore session" with last opened session before close


Expected results:

Firefox should display home page as defined in Preferences

Comment 1 Martin Stransky 2015-07-06 12:32:33 UTC
Thanks for the bug report, fix is on the way.

Comment 2 Martin Stransky 2015-07-06 12:51:43 UTC
Upstream bug - https://bugzilla.mozilla.org/show_bug.cgi?id=884831

Comment 4 Didier G 2015-07-06 13:41:09 UTC
Problem still exists, not fixed for me by firefox-39.0-7.fc22.x86_64

I deleted tried to delete ~/.mozilla but no change.

Comment 5 John Cox 2015-07-06 14:47:34 UTC
I am having the opposite problem with 39.0.6.
My preferene is set for restoring the previous session and it does not.
Restore from history works.

Comment 6 John Cox 2015-07-06 14:55:16 UTC
I am having the opposite problem with 39.0.6.
My preferene is set for restoring the previous session and it does not.
Restore from history works.

Comment 7 Remi Collet 2015-07-06 15:16:59 UTC
39.0-7 doesn't seems to solves the bug.

Each time I launch FF (configured to displayed by home page), it display the "restore session after crash" page.

Comment 8 Remi Collet 2015-07-06 15:51:01 UTC
Notice: I can reproduce this issue using a fresh new profile (firefox-39.0-7.fc21)

Comment 9 Gerald Cox 2015-07-06 16:32:08 UTC
*** Bug 1239231 has been marked as a duplicate of this bug. ***

Comment 10 Steve 2015-07-07 04:15:52 UTC
Firefox-39.0-7.fc22 does not solve this problem for me.

Comment 11 Martin Stransky 2015-07-07 07:58:26 UTC
I see. Thanks for the feedback.

Comment 12 Martin Stransky 2015-07-07 12:00:46 UTC
This bug seems to be cause by a Fedora specific patch. Still investigating.

Comment 13 Christian Stadelmann 2015-07-07 12:55:39 UTC
I set firefox to always show the profile manager before starting.
With the update to 39.0 I noticed that I get the profile manager twice every time I start firefox. It does not apply to all profiles though.

Comment 14 poma 2015-07-08 09:24:42 UTC
$ gdb firefox ...
GNU gdb (GDB) Fedora 7.9.50.20150531-4.fc23
...
"/usr/bin/firefox": not in executable format: File format not recognized
(gdb) run
Starting program:  
No executable file specified.
Use the "file" or "exec-file" command.
(gdb) exec-file firefox
"/usr/bin/firefox": not in executable format: File format not recognized
(gdb) file /usr/bin/firefox
"/usr/bin/firefox": not in executable format: File format not recognized
(gdb) quit

$ gdb /usr/lib64/firefox/firefox-bin ...
...
Reading symbols from /usr/lib64/firefox/firefox-bin...Reading symbols from /usr/lib/debug/usr/lib64/firefox/firefox-bin.debug...done.
done.
...
(gdb) run
Starting program: /usr/lib64/firefox/firefox-bin 
...
(gdb) backtrace full
No stack.
(gdb) quit


 - Conclusion -

While it runs indirectly - via script ("This script is meant to run a mozilla program from the mozilla rpm installation"):
$ /usr/bin/firefox

it'll go: "We're Sorry" Firefox had a problem and crashed. ... routine.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

In contrast to "script mode", while it runs directly:
$ /usr/lib64/firefox/firefox-bin

no problemos whatsoever.


firefox-39.0-7.fc23.x86_64
firefox-debuginfo-39.0-7.fc23.x86_64

Comment 15 Martin Stransky 2015-07-08 09:35:47 UTC
(In reply to poma from comment #14)
>  - Conclusion -
> 
> While it runs indirectly - via script ("This script is meant to run a
> mozilla program from the mozilla rpm installation"):
> $ /usr/bin/firefox
> 
> it'll go: "We're Sorry" Firefox had a problem and crashed. ... routine.

Good catch! It's caused by "firefox -remote 'ping()'" command which crashes and then (in regular FF launch) Firefox takes this crash as normal FF crash and tries to restore the session.

Comment 16 poma 2015-07-08 14:58:57 UTC
I commented on the entire "MOZILLA_DOWN" section, so far works OK.
Gonna emerge some defect, we will see.

BTW take a look at this paragraph, if you haven't already
https://developer.mozilla.org/en-US/docs/Mozilla/Command_Line_Options#-remote_remote_command

Comment 17 Didier G 2015-07-08 22:08:22 UTC
firefox-39.0-8.fc22.x86_64 available on koji fixes this problem for me.

Thanks to Martin for his efforts.

Comment 18 Colin J Thomson 2015-07-08 22:11:55 UTC
Fixes it for me as well on F21.x86_64, Thanks.

Comment 19 Steve 2015-07-09 03:39:06 UTC
Yep, bug fixed, thanks a lot!

Comment 20 Remi Collet 2015-07-09 04:34:22 UTC
I confirm that firefox-39.0-8.fc21 fix this issue, thanks.

Comment 21 poma 2015-07-09 05:39:02 UTC
This fix actually doesn't require expanded testing, therefore
+2
firefox-39.0-8.fc23.x86_64
firefox-39.0-8.fc22.x86_64


Note You need to log in before you can comment on or make changes to this bug.