Bug 123947 - (PATCH) missing file in logrotate config for ppp
Summary: (PATCH) missing file in logrotate config for ppp
Status: CLOSED DUPLICATE of bug 122911
Alias: None
Product: Fedora
Classification: Fedora
Component: ppp (Show other bugs)
(Show other bugs)
Version: 2
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-21 21:37 UTC by Brad Bailey
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:03:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brad Bailey 2004-05-21 21:37:53 UTC
Description of problem:

The logrotate config file included with the ppp package references a 
file /var/log/ppp/connect-errors that is not created by default. This 
causes an error to be reported whenever logrotate is run, resulting 
in needless daily emails to root from the logrotate cronjob.

Version-Release number of selected component (if applicable):

The ppp version is 2.4.2-2. This seems to be a new issue for Fedora 
Core 2; FC1 did not include logrotate configuration.

How reproducible:

ppp is part of the dialup package group, included in @base, and would 
have to be specifically excluded from installation. Any FC2 system 
that doesn't use ppp would never generate the file to be rotated.

Steps to Reproduce:
1. Install Fedora Core 2
2. Don't use ppp
3. Wait for the daily cron run-parts or anacron to run logrotate
  
Actual results:
Root receives a regular email detailing the missing file.

Expected results:
Root lives a happy life never having known about the missing file.

Additional info:
'missingok' in /etc/logrotate.d/ppp would be the fix, no?

Comment 1 Thomas Woerner 2004-05-24 08:25:08 UTC

*** This bug has been marked as a duplicate of 122911 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:03:29 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.