Bug 122911 - Logrotate problem if ppp isn't used and there isn't a logfile in /var/log
Summary: Logrotate problem if ppp isn't used and there isn't a logfile in /var/log
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ppp   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Keywords:
: 123947 124817 126479 126771 127584 127741 (view as bug list)
Depends On:
Blocks: FC2Target 126479
TreeView+ depends on / blocked
 
Reported: 2004-05-10 12:30 UTC by Robert Scheck
Modified: 2007-11-30 22:10 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-13 09:09:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2004-05-10 12:30:32 UTC
Description of problem:
There's a logrotate problem if ppp isn't used and there isn't a 
logfile in /var/log:

--- snipp ---
/etc/cron.daily/logrotate:

error: stat of /var/log/ppp/connect-errors failed: No such file or directory
--- snapp ---

--- snipp ---
May  9 04:02:10 tux syslogd 1.4.1: restart.
May  9 04:02:10 tux logrotate: ALERT exited abnormally with [1]
--- snapp ---

Version-Release number of selected component (if applicable):
ppp-2.4.2-2

How reproducible:
Everytime

Steps to Reproduce:
1. Install ppp-2.4.2-2
2. Wait a for logrotate
3. Get the error in syslog/logwatch
  
Actual results:
Maybe a "missingok" in /etc/logrotate.d/ppp solves the problem?

Expected results:
No error at logrotate for ppp.

Additional info:
If ppp-2.4.2-2 is shipped with Fedora Core 2, it is a also a problem
there.

Comment 1 Robert Scheck 2004-05-10 12:43:36 UTC
Yupp, 

--- $SOURCES/ppp.logrotate            2004-05-07 12:37:26.000000000 +0200
+++ $SOURCES/ppp.logrotate.rsc        2004-05-10 14:33:55.000000000 +0200
@@ -1,6 +1,7 @@
 # Logrotate file for ppp RPM

 /var/log/ppp/connect-errors {
+       missingok
        compress
        notifempty
        daily

solves it for me.

Comment 2 Thomas Woerner 2004-05-13 15:51:26 UTC
Fixed in rawhide in rpm ppp-2.4.2-2.1 or newer.

Comment 3 Robert Scheck 2004-05-13 17:56:51 UTC
Thank you, but could you also make an update for Fedora Core 2, if this
fix (and I believe that) isn't in Fedora Core 2? Would be very nice :)

Comment 4 Joe Orton 2004-05-17 18:51:28 UTC
Seconded that comment since this mails errors to root on a default
@Everything FC2 install for every logrotate run.

Comment 5 Matthew Miller 2004-05-20 17:13:33 UTC
Anyone updating to the rawhide package probably wants to check out bug
#123680 first....

Comment 6 Thomas Woerner 2004-05-24 08:25:10 UTC
*** Bug 123947 has been marked as a duplicate of this bug. ***

Comment 7 Guðmundur D. H. 2004-06-07 19:15:23 UTC
*** Bug 124817 has been marked as a duplicate of this bug. ***

Comment 8 Robert Scheck 2004-06-22 12:55:12 UTC
Requesting an update for Fedora Core 2 again, to solve this issue and
bug #123680 for the end users and not only in development...

Comment 9 Thomas Woerner 2004-06-22 13:32:49 UTC
*** Bug 126479 has been marked as a duplicate of this bug. ***

Comment 10 Penelope Fudd 2004-06-23 18:21:15 UTC
Also seconding (thirding?) the update request for Fedora Core 2.

Comment 11 Robert Scheck 2004-07-08 18:09:16 UTC
Well, could somebody please tell me, what's such hard at a simple 
rebuild of the latest ppp from Development for Fedora Core 1? Or is
the package just hanging at the quality assurance *eg*?! ;-)

Comment 12 Robert Scheck 2004-07-08 18:10:16 UTC
Oops...sorry, I meant Fedora Core 2 instead of 1 - my mistake!

Comment 13 Miloslav Trmac 2004-07-11 13:37:20 UTC
*** Bug 127584 has been marked as a duplicate of this bug. ***

Comment 14 Thomas Woerner 2004-07-13 08:51:04 UTC
*** Bug 127741 has been marked as a duplicate of this bug. ***

Comment 15 Thomas Woerner 2004-07-13 08:53:09 UTC
*** Bug 126771 has been marked as a duplicate of this bug. ***

Comment 16 Thomas Woerner 2004-07-13 09:09:03 UTC
Fixed in FC2-updates. The conflict with initscripts is solved by a new
initscripts package.


Note You need to log in before you can comment on or make changes to this bug.