Bug 123956 - Yamaha opl3-sax isapnp sound card drivers not installed at boot
Yamaha opl3-sax isapnp sound card drivers not installed at boot
Status: CLOSED DUPLICATE of bug 115885
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-21 19:29 EDT by Michael R. Mayne
Modified: 2014-03-16 22:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
System logs from initial install of FC2 thru today (3-4 days) (347.82 KB, text/plain)
2004-05-21 19:34 EDT, Michael R. Mayne
no flags Details

  None (edit)
Description Michael R. Mayne 2004-05-21 19:29:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Y'all go easy on me, this is my first time posting a bug here.

I have an older system (PIII 450MHZ, 440BX chipset) that has an ISA
PNP sound card that is not detected and installed correctly.  This
occurs on both Fedora Core 1 and Fedora Core 2.  However, I have
gotten the card to work by manual configuration.  Let me go over what
I've done so far, and you tell me what to do from here.

After trying initially to get the card to work under FC2T3 without
success, I installed FC1 and tried with that.  The card was not
detected and installed correctly, but I got some info on it with a
utility (can't remember which) that had output of the following form:

Card 1 'YMH0020:OPL3-SAX Sound Board' PnP version 1.0
  Logical device 0 'YMH0021:Unknown'
    Device is active
    Active port 0x240,0xe80,0x338,0x300,0x100
    Active IRQ 7 [0x2]
    Active DMA 1,3
    Resources 0
      (yada yada yada)

Given these clues, I manually ran the 'SNDCONFIG --noprobe' utility
under FC1 and created / updated the following files (which caused
everything to start working):

file modprobe.conf (unchanged):

include /etc/modprobe.conf.dist
alias eth0 tulip
alias scsi_hostadapter aic7xxx

file modules.conf:

alias eth0 tulip
alias scsi_hostadapter aic7xxx
alias usb-controller usb-uhci
alias sound-slot-0 opl3sa2
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L
>/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S
>/dev/null 2>&1 || :
options sound dmabuf=1
alias synth0 opl3
options opl3 io=0x388
options opl3sa2 mss_io=0xe80 irq=7 dma=1 dma2=3 mpu_io=0x330 io=0x380

file soundcard:

# THIS FILE IS WRITTEN BY SNDCONFIG
# PLEASE USE SNDCONFIG TO MODIFY
# TO CHANGE THIS FILE!
# There should be no spaces at the start of a line
# or around the '=' sign
CARDTYPE=OPL3_SAX

Now, when I installed FC2, the card was detected, but the drivers were
not installed, and I received the following error messages in the
System log:

modprobe: FATAL: Error running install command for sound_slot_0 
modprobe: FATAL: Error running install command for sound_slot_0 
modprobe: FATAL: Error running install command for sound_slot_1 
modprobe: FATAL: Error running install command for sound_slot_0 
modprobe: FATAL: Error running install command for sound_slot_0 
modprobe: FATAL: Error running install command for sound_slot_1 

I then tried the following manual hack to /etc/modprobe.conf (based on
the info I got from the configuration under FC1) and the card started
working and all was well:

alias eth0 tulip
alias scsi_hostadapter aic7xxx
alias usb-controller uhci-hcd
#
# following lines added manually to correctly install sound drivers
#
alias sound-slot-0 snd-opl3sa2
alias sound-slot-1 snd-mpu401-uart
options sound dmabuf=1
alias synth0 opl3
options opl3 io=0x388
options opl3sa2 mss_io=0xe80 irq=7 dma=1 dma2=3 mpu_io=0x330 io=0x380

OK, that's all I can report so far.  Where to go / what to do next?

Thanks.
-Mike

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358

How reproducible:
Always

Steps to Reproduce:
See description

Actual Results:  Sound card drivers not installed, errors recorded in
system log, no sound.

Expected Results:  Opposite of actual results

Additional info:

See description.  If I should have formatted / entered the information
differently, please instruct me.  I searched the Bugzilla database,
and the only thing similar I could find was #116078, but I'm not sure
its a close enough match.
Comment 1 Michael R. Mayne 2004-05-21 19:34:47 EDT
Created attachment 100436 [details]
System logs from initial install of FC2 thru today (3-4 days)
Comment 2 Bill Nottingham 2004-05-25 12:32:53 EDT

*** This bug has been marked as a duplicate of 115885 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:03:30 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.