Bug 115885 - (kudzu-isapnp) kudzu does not handle 2.6 ISAPnP correctly
kudzu does not handle 2.6 ISAPnP correctly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 102366 115670 123956 124003 124082 124112 124784 125175 125265 134635 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-16 16:01 EST by Fred New
Modified: 2014-03-16 22:42 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 01:06:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred New 2004-02-16 16:01:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
I was able to configure this isapnp device using sndconfig in FC1.  My
FC2-test1 dmesg shows

..
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
isapnp: Scanning for PnP cards...
isapnp: Card 'CS4235 CODEC'
isapnp: 1 Plug & Play card detected total
pty: 2048 Unix98 ptys configured
..

But when I run system-config-soundcard from Gnome terminal, I get the
following:

# system-config-soundcard
 
** (system-config-soundcard.py:1941): WARNING **: `GtkTextSearchFlags'
is not an enum type

and a message window displays, "No soundcards were detected."



Version-Release number of selected component (if applicable):
system-config-soundcard-1.2.2-1

How reproducible:
Always

Steps to Reproduce:
1. Run system-config-soundcard from Gnome terminal or from Red Hat ->
System Settings -> Soundcard Detection


Actual Results:  No soundcards were detected.

Expected Results:  Soundcard detected and sound using the snd-cs4236
driver.

Additional info:

kudzu doesn't detect this device either.
Comment 1 Bill Nottingham 2004-02-17 00:23:51 EST
There appears to be no isapnpmap files created by the kernel anymore -
intentional?
Comment 2 Dave Jones 2004-02-17 07:32:02 EST
I'm unaware we ever did generate any.
Comment 3 Bill Nottingham 2004-02-17 10:55:11 EST
In 2.4, both ALSA and OSS generated ISAPnP module tables. Maybe it's a
module-init-tools misfeature. :/
Comment 4 Bill Nottingham 2004-05-25 12:32:26 EDT
kudzu isn't handling 2.6 ISAPnP correctly.
Comment 5 Bill Nottingham 2004-05-25 12:32:58 EDT
*** Bug 123956 has been marked as a duplicate of this bug. ***
Comment 6 Bill Nottingham 2004-05-25 12:34:55 EDT
*** Bug 124003 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 2004-05-25 12:36:51 EDT
*** Bug 124082 has been marked as a duplicate of this bug. ***
Comment 8 Bill Nottingham 2004-05-25 15:57:13 EDT
*** Bug 124112 has been marked as a duplicate of this bug. ***
Comment 9 Kyrre Ness Sjøbæk 2004-05-26 13:18:06 EDT
Okay... I've confirmed that sound works when i do "modprobe
snd-sbawe", but how do I make this happen each time i boot the computer?
Comment 10 Andre Robatino 2004-05-28 06:23:01 EDT
  The CS4235 used to be detected and configured automatically at least
as far back as RH 6.0, but stopped being detected somewhere around RH
9, when sndconfig stopped being the default tool (sndconfig continued
to work until now, but it can't be used anymore).  The following 4
lines in modprobe.conf, inspired by using automatically generated
lines on another machine as a template and changing the driver, seem
to work for me (the install and remove lines are each one line that
appears as two due to wraparound):

alias snd-card-0 snd-cs4236
options snd-cs4236 isapnp=1
install snd-cs4236 /sbin/modprobe --ignore-install snd-cs4236 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-cs4236 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-cs4236
Comment 11 Bill Nottingham 2004-06-01 01:05:16 EDT
*** Bug 124784 has been marked as a duplicate of this bug. ***
Comment 12 Andre Robatino 2004-06-01 01:58:09 EDT
  Correction to my previous comment - the CS4235 stopped being
detected in RH 8.0, when redhat-config-soundcard (now
system-config-soundcard) became the default configuration tool.  This
tool has _never_ been able to detect the CS4235, though sndconfig
always could.
Comment 13 Bill Nottingham 2004-06-03 12:49:40 EDT
*** Bug 125175 has been marked as a duplicate of this bug. ***
Comment 14 Bill Nottingham 2004-06-04 16:29:06 EDT
*** Bug 125265 has been marked as a duplicate of this bug. ***
Comment 15 Michael R. Mayne 2004-06-22 11:47:59 EDT
We may be seeing some progress here - I tried the latest 2.6.7 kernel 
and the latest kudzu (kernel-2.6.7-1.441.i686.rpm, kernel-utils-2.4-
11.i386.rpm, kudzu-1.1.70-1.i386.rpm, kudzu-devel-1.1.70-1.i386.rpm) 
last night - kudzu recognised new hardware (YMH08xx) on reboot .  I 
haven't actually gotten any sound yet, but the volume control seems 
to work (doesn't immediately drop back to zero), and alsamixer 
immediately recognizes an OPL3SA2 sound card.  I think this is due to 
changes in the following file: linux-2.6.7\sound\isa\opl3sa2.c.  I 
did this on a fresh reinstall of FC2 with just the updates-released-
fc2 updates applied.  Any other updates from the development tree 
that I should apply?  BTW, where do I find the RPM GPG key for the 
Development (Rawhide) tree?

-Mike
Comment 16 Bill Nottingham 2004-06-28 16:45:43 EDT
rawhide isn't signed, generally.

There is test code for this in development; the problem is that I
wanted to flesh out a few other (non-ISAPnP) bugs before doing a test
update.

(And yes, the device descriptions for ISAPnP devices will be *ugly* -
there's really no correlating descriptive info from the kernel in sysfs.)
Comment 17 Bill Nottingham 2004-07-14 15:02:04 EDT
*** Bug 115670 has been marked as a duplicate of this bug. ***
Comment 18 Chaz 2004-08-01 23:19:44 EDT
So, is there a fix out yet?
Comment 19 Bill Nottingham 2004-08-02 15:31:43 EDT
The package in rawhide may work for you.
Comment 20 Bill Nottingham 2004-09-30 00:53:17 EDT
*** Bug 102366 has been marked as a duplicate of this bug. ***
Comment 21 Bill Nottingham 2004-09-30 00:56:20 EDT
1.1.91-1 will have better ISAPnP description strings as well.
Comment 22 Bill Nottingham 2004-09-30 01:06:50 EDT
Closing as 'rawhide'.
Comment 23 Bill Nottingham 2004-10-05 11:44:17 EDT
*** Bug 134635 has been marked as a duplicate of this bug. ***
Comment 24 Andre Robatino 2004-11-10 04:08:47 EST
  On a clean install of FC3, I get no sound even though modprobe.conf
appears more or less correct.  There is only a one-line difference
between the automatically generated file and the one I used in FC2 and
given in comment #10: instead of the line

options snd-cs4236 isapnp=1

the automatically generated file has the line

options snd-card-0 index=0

and I tried replacing this line with the original one with no luck.  I
tried fiddling with all the volume controls.  If this is confirmed,
this should be bumped up to FC3.
Comment 25 Bill Nottingham 2004-11-10 12:53:48 EST
The failure of the sound driver to produce output is generally
unrelated to kudzu.
Comment 26 FC Better Than Windows 2004-12-01 02:05:22 EST
I have tried to find correction for this bug for FC2, but it seems
that FC policy is not to fix anything for anywhere else than the
latest release. Is this correct intepretation?
Comment 27 Dave Jones 2004-12-01 02:07:20 EST
the fc2 & fc3 kernels are 99.9% the same, so if this still affects fc2
with the 2.6.9 kernel update, it very likely also affects fc3.
Comment 28 Dave Jones 2004-12-01 02:09:16 EST
brainfart -- ignore last comment, I just realised this is a kudzu bug,
not a kernel bug.
Comment 29 Bill Nottingham 2004-12-01 11:22:49 EST
If there is a need to push another kudzu fix for FC2, this will
probably be fixed at the same time.

Note You need to log in before you can comment on or make changes to this bug.