Bug 123968 - Versioned obsoletes not supported, compat* installed on upgrade
Versioned obsoletes not supported, compat* installed on upgrade
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
FC3
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-22 01:41 EDT by Pavel Roskin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-24 03:05:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Roskin 2004-05-22 01:41:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040506 Firefox/0.8

Description of problem:
When upgrading FC2 to FC2 (in attempt to fix some unrelated problems),
anaconda installed a bunch of compat* packages.  It happened because
anaconda treats versioned obsoletes as non-versioned ones.  For
example, compat-db obsoletes db4 older than version 4.2.  Anaconda
finds db4 installed and decides that compat-db obsoletes it.  
The version of db4 is not checked.

See also bug #123911.  While yum tries to support versioned obsoletes
but does it wrong, anaconda doesn't even try.  From file
findpackageset.py in anaconda sources:

# FIXME: I should really iterate over all matches and verify
# versioned obsoletes, but nothing in Red Hat Linux uses
# them, so I'll optimize

This statement is incorrect for Fedora Core 2.


Version-Release number of selected component (if applicable):
anaconda-10.0-5

How reproducible:
Didn't try

Steps to Reproduce:
1.Install FC2 from CD (Workstation, English, all default).
2.Upgrade that installation to FC2 using the same CD in the same
configuration.
    

Actual Results:  Several new packages are installed.  They all start
with "compat".  "compat-db" is one of them.

Expected Results:  No packages need to be installed.

Additional info:
Comment 2 Paul Nasrat 2004-06-10 03:43:31 EDT
I've fixed this so anaconda now does EVR label comparison of obsoletes.

Tested using FC2 upgrade on FC2 and no additional packages are installed.

Note You need to log in before you can comment on or make changes to this bug.