Bug 123989 - Complicated cyrus-imapd obsoletes simple uw-imapd
Complicated cyrus-imapd obsoletes simple uw-imapd
Status: CLOSED DUPLICATE of bug 127448
Product: Fedora
Classification: Fedora
Component: cyrus-imapd (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
Depends On:
  Show dependency treegraph
Reported: 2004-05-22 11:25 EDT by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:03:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-05-22 11:25:48 EDT
Description of problem:
The compilicated and full-featured cyrus-imapd obsoletes simple small 
uw-imapd and replaces uw-imapd as new default imap server (matches 
with the release notes) at a update from FC1 to FC2. BUT if I do a 
new fresh install, my default imap server is dovecot, because dovecot 
is marked as default imap server in comps.xml. So what's right?!

I think, cyrus-imapd shouldn't be the default imap server, because
it doesn't run out-of-the-box as uw-imapd and dovecot do - so if you
read the mailing list, there are many many users having problems with 
the more flexible cyrus-imapd...most of them had before the very 
simple uw-imapd ;-)

Version-Release number of selected component (if applicable):
comps.xml of FC2
release notes of FC2

Actual results/Expected results:
Please add obsoletes/provides for imap to dovecot and remove the 
obsoleting for imap from cyrus-imapd.

Additional info:
Dovecot really should be the default imap server to prevent lots of
stupid user problems, caused by the snugness of them.
Comment 1 vigna 2004-08-30 11:57:34 EDT
I completely agree. I've spent the last 4 hours trying to make, in
turn, work the old uw-imap, then cyrus-imapd, and finally dovecot. No
success. I cannot read my mail, period.

This kind of disruptive changes in fundamental services are giving
Fedora a very bad name.

Most incredibly, this problem isn't EVEN MENTIONED in the Release
Notes. I would have expected a migration path of some kind.
Comment 2 Robert Scheck 2004-08-30 12:49:11 EDT
Well, I personally don't like dovecot, but that isn't the reason 
of my bug report. I'm not against dovecot, but the obsoletes/provides 
statements inside of those both spec files simply seem *wrong* to me.

Red Hat always talked about that dovecot replaces uw-imap, but the 
typical behaviour we had with uw-imap in the past (default imap/pop 
server etc), is lost.

For comment #1: Change from uw-imap to dovecot (and also back) worked 
everytime, I needed very well. If you want to have *my* imap-2004a-1 
src/binary rpm, write me an e-mail and you can get it.
Comment 6 John Dennis 2004-08-30 13:49:11 EDT
I believe this was fixed when bug #127448 was closed. There was
unfortunately an "obsoletes: imap" in the cyrus-imap spec file and
that came along for the ride when we utilized an upstream spec file
and its inclusion was initially unnoticed. That tag has been removed.

Now neither cyrus-imap nor dovecot have either an obsoltes tag nor a
provides tag. At the moment we believe this represents the optimal
behavior, as a consequence I'm going to close this as a dup of bug
#127448 (BTW, bug #129274 is related)

If you believe removing the obsoltes tag does not address your problem
please reopen the bug and bring your concerns to our attention.

*** This bug has been marked as a duplicate of 127448 ***
Comment 7 Rex Dieter 2004-08-30 13:56:33 EDT
FYI,  see also (uw) imap fedora.us submission:
Comment 8 Red Hat Bugzilla 2006-02-21 14:03:32 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.