Bug 124003 - FC2 Final does not configure AWE64 ISA PNP sound card
FC2 Final does not configure AWE64 ISA PNP sound card
Status: CLOSED DUPLICATE of bug 115885
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-22 16:08 EDT by Earl Terwilliger
Modified: 2014-03-16 22:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Earl Terwilliger 2004-05-22 16:08:54 EDT
Description of problem: 
 
AWE 64 PNP not configured via Fedora Core 2 (final) at install time. 
 
The kernel detects the AWE card but kudzu does not detect it and 
there is no reference to it in /etc/sysconfig/hwconf. There is 
nothing configured for it in /etc/modprobe.conf either.  
 
system-config-soundcard says no sound cards are detected 
 
Manually loading the driver via: 
 
modprobe snd-sbawe 
 
detects the card and loads the drivers but that does not configure it 
properly to play any sound.... 
 
I tried fresh full install of FC2 on two different machines (both 
with an ISA AWE 64 PNP card) with same results. This is the output of 
the kernel startup referencing the detection of the card: 
 
May 20 00:35:45 Linuxworks kernel: isapnp: Scanning for PnP cards... 
May 20 00:35:45 Linuxworks kernel: pnp: SB audio device quirk - 
increasing port range 
May 20 00:35:45 Linuxworks kernel: pnp: AWE32 quirk - adding two 
ports 
May 20 00:35:45 Linuxworks kernel: isapnp: Card 'Creative SB AWE64 
PnP' 
May 20 00:35:45 Linuxworks kernel: isapnp: 1 Plug & Play card 
detected total 
 
 
Version-Release number of selected component (if applicable): 
Fedora Core 2 (final) fresh full install 
 
How reproducible: 
always 
 
Steps to Reproduce: 
1. Install fresh FC2 final on a system with an AWE 64 PNP ISA sound 
   card 
2. 
3. 
   
Actual results: 
AWE 64 ISA pnp card not configured and plays no sound 
 
 
Expected results: 
/etc/modprobe.conf configured for AWE64 PNP ISA sound card 
and correct playing of sound 
 
 
 
Additional info: 
Both of these machines were running Fedora Core 1 fine and both of 
the sound cards worked fine under FC 1.
Comment 1 Ricky Ng-Adam 2004-05-24 14:50:37 EDT
I had reported this on the testers mailing list and Alan Cox replied:

"It isnt autoconfigured for ISA devices any more, but should work if
you sent ALSA up by hand. (I'm of the opinion isapnp audio ought to be
autoconfigured tho)"

However, I don't know how...  I've looked at the alsa-utils README,
and it talks about alsaconf but that utility isn't provided by the RPM!
Comment 2 Bill Nottingham 2004-05-25 12:34:52 EDT

*** This bug has been marked as a duplicate of 115885 ***
Comment 3 Pavel Tsekov 2004-06-03 05:03:35 EDT
To the original poster:

I have the same card on an old (1999) ASUS P5A (ALI Alladin V) board
with a K6/2-350 Mhz. Tonight after playing for several hours I've
found out that the SB is actually working after "modprobe snd-sbawe"
command - but it is mute. To hear actual sound start 'alsamixer' and
unmute/raise the volume for any of the interfaces that are required to
play sound 'PCM', 'Master Playback' , 'Playback' .. For me it was the
'PCM'. After that I was able to hear sound played by the 'aplay' utility.

I hope this help. I spend quite a lot of time to figure it out so I
guess its worth saving someone elses time :)
Comment 4 Red Hat Bugzilla 2006-02-21 14:03:33 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.