Bug 1240101 - Hard Coded paths to openstack-heat-triple-o-heat-templates
Summary: Hard Coded paths to openstack-heat-triple-o-heat-templates
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: ga
: Director
Assignee: Dougal Matthews
QA Contact: Ola Pavlenko
URL:
Whiteboard:
: 1235622 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-05 23:14 UTC by Graeme Gillies
Modified: 2015-08-05 13:58 UTC (History)
10 users (show)

Fixed In Version: python-rdomanager-oscplugin-0.0.8-33.el7ost
Doc Type: Bug Fix
Doc Text:
The director used hard coded paths to the Heat template collection in /usr/share/openstack-tripleo-heat-templates/. This caused problems when using a custom Heat template e.g. creating a local copy and customizing it. This fix provides variable input with the --template argument. Users can now create an Overcloud with a customised Heat template collection.
Clone Of:
Environment:
Last Closed: 2015-08-05 13:58:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 239444 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Graeme Gillies 2015-07-05 23:14:35 UTC
Hi,

So I've been attempting to experiment with some customisation of
deployments by utilising the tripleo heat templates and modifying the
post deployment to include some extra setup I want done to my nodes (in
this case, deploying some monitoring and logging agents onto the machines)

I was very silly and niavely assuming that I could take a copy of
openstack-tripleo-heat-templates into my local dir, and run overcloud
deploy like

openstack overcloud deploy --use-tripleo-heat-templates --tripleo-root
/home/stack/openstack-tripleo-heat-templates

And it would utilise the copy I had taken with all my modifications.

So when this didn't work (it deployed without my changes) I was very confused and had a look in the code. It seems that tripleo-root defaults to

/etc/tripleo

Which contains 5 files which I for the life of my can not make heads or
tails of what they actually do. Likewise, looking at the code to see how
I can make the unified cli use my local copy of
openstack-triple-o-heat-templates I see

TRIPLEO_HEAT_TEMPLATES = "/usr/share/openstack-tripleo-heat-templates/"
OVERCLOUD_YAML_PATH = os.path.join(TRIPLEO_HEAT_TEMPLATES,
                                   "overcloud-without-mergepy.yaml")

They are hardcoded. Can we please have these not hard coded, and configured with a command line switch (e.g. --tripleo-heat-templates-root)

Thanks,

Graeme

Comment 3 chris alfonso 2015-07-06 16:13:47 UTC
J, would you mind updating this with doc'd steps?

Comment 5 chris alfonso 2015-07-06 16:59:20 UTC
*** Bug 1240123 has been marked as a duplicate of this bug. ***

Comment 6 Dougal Matthews 2015-07-07 07:09:51 UTC
I'm not sure why this went to jdob rather than akrivoka.

This would be a very simple change in the CLI, it has always been planned but nobody had quite gotten around to it.

Comment 7 Dougal Matthews 2015-07-09 16:48:18 UTC
Would it make sense for us to change --use-tripleo-heat-templates to --templates and require users pass in the directory? i.e. --templates=/usr/share/openstack-tripleo-heat-templates/

A bit annoying if you don't want to change anything, but it is for advanced users... and then it shows them where to grab a copy

Comment 8 Dougal Matthews 2015-07-09 16:55:30 UTC
We could easily do the suggestion in https://bugzilla.redhat.com/show_bug.cgi?id=1240101#c7 by adding a new --templates and leaving --use-tripleo-heat-templates as it is.

Comment 9 Graeme Gillies 2015-07-10 01:06:19 UTC
(In reply to Dougal Matthews from comment #8)
> We could easily do the suggestion in
> https://bugzilla.redhat.com/show_bug.cgi?id=1240101#c7 by adding a new
> --templates and leaving --use-tripleo-heat-templates as it is.

Sounds good to me

Comment 10 Dougal Matthews 2015-07-10 11:56:48 UTC
Patch midstream: https://review.gerrithub.io/#/c/239444/

After some discussion we went for a --template-root argument.

Comment 11 Dougal Matthews 2015-07-14 08:12:22 UTC
After some discussions and an issue with the first patch, a second one has been added. https://review.gerrithub.io/239646

Comment 13 Dougal Matthews 2015-07-16 12:32:13 UTC
*** Bug 1235622 has been marked as a duplicate of this bug. ***

Comment 15 Ola Pavlenko 2015-08-04 08:38:20 UTC
python-rdomanager-oscplugin-0.0.8-43.el7ost.noarch

Comment 17 errata-xmlrpc 2015-08-05 13:58:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.