Bug 1240184 - snap-view:mount crash if debug mode is enabled
Summary: snap-view:mount crash if debug mode is enabled
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1245908 1245915
TreeView+ depends on / blocked
 
Reported: 2015-07-06 07:17 UTC by Mohammed Rafi KC
Modified: 2016-06-16 13:19 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1245908 1245915 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:19:46 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohammed Rafi KC 2015-07-06 07:17:21 UTC
Description of problem:

from snpaview-server, for statfs fops we allocate memory for loc->path directly, instead of using GF_CALLOC/GF_MALLOC, that causes assertion failure and crash if debug mode is enabled during configurations.

Version-Release number of selected component (if applicable):

mainline

How reproducible:

100%

Steps to Reproduce:
1.enablde debig mode during building using ./configure --enable-debug
2.create volume start it
3.enable uss
4.create an activate snapshot
5.check getconf NAME_MAX /mnt/.snaps

Actual results:

this causes mount process to crash

Expected results:

should not crash mount point

Additional info:

Comment 1 Anand Avati 2015-07-06 07:28:55 UTC
REVIEW: http://review.gluster.org/11543 (snapview-client: Allocate memory using GF_CALLOC) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Anand Avati 2015-07-06 10:59:17 UTC
REVIEW: http://review.gluster.org/11543 (snapview-client: Allocate memory using GF_CALLOC) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 3 Nagaprasad Sathyanarayana 2015-10-25 15:05:47 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 4 Niels de Vos 2016-06-16 13:19:46 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.