Bug 1245908 - snap-view:mount crash if debug mode is enabled
Summary: snap-view:mount crash if debug mode is enabled
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: 3.7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact:
URL:
Whiteboard:
Depends On: 1240184 1245915
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-23 06:01 UTC by Avra Sengupta
Modified: 2015-07-30 09:51 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1240184
Environment:
Last Closed: 2015-07-30 09:51:32 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Avra Sengupta 2015-07-23 06:01:39 UTC
+++ This bug was initially created as a clone of Bug #1240184 +++

Description of problem:

from snpaview-server, for statfs fops we allocate memory for loc->path directly, instead of using GF_CALLOC/GF_MALLOC, that causes assertion failure and crash if debug mode is enabled during configurations.

Version-Release number of selected component (if applicable):

mainline

How reproducible:

100%

Steps to Reproduce:
1.enablde debig mode during building using ./configure --enable-debug
2.create volume start it
3.enable uss
4.create an activate snapshot
5.check getconf NAME_MAX /mnt/.snaps

Actual results:

this causes mount process to crash

Expected results:

should not crash mount point

Additional info:

--- Additional comment from Anand Avati on 2015-07-06 03:28:55 EDT ---

REVIEW: http://review.gluster.org/11543 (snapview-client: Allocate memory using GF_CALLOC) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Anand Avati on 2015-07-06 06:59:17 EDT ---

REVIEW: http://review.gluster.org/11543 (snapview-client: Allocate memory using GF_CALLOC) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 1 Anand Avati 2015-07-23 08:39:44 UTC
REVIEW: http://review.gluster.org/11743 (snapview-client: Allocate memory using GF_CALLOC) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Anand Avati 2015-07-26 15:11:25 UTC
COMMIT: http://review.gluster.org/11743 committed in release-3.7 by Niels de Vos (ndevos@redhat.com) 
------
commit 086d1c40b68bc2ba10851383af6c8028c3f02f1d
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Mon Jul 6 12:15:45 2015 +0530

    snapview-client: Allocate memory using GF_CALLOC
    
    loc->path memory should allocate through
    GF_CALLOC/GF_MALLOC, since it uses GF_FREE
    from loc_wipe.
    
    Back port of :
    >Change-Id: If3030175dfb07b0e0b6c0a30234857f8a0780035
    >BUG: 1240184
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/11543
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    >Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    
    (cherry picked from commit 32207db25eea821dfb1abd033df1013d4b8fc622)
    
    Change-Id: I69f9338dc5ae9950b5344000259558423c3f8618
    BUG: 1245908
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/11743
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 3 Kaushal 2015-07-30 09:51:32 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.