Bug 1240210 - Metadata self-heal is not handling failures while heal properly
Summary: Metadata self-heal is not handling failures while heal properly
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1243644
TreeView+ depends on / blocked
 
Reported: 2015-07-06 08:24 UTC by Pranith Kumar K
Modified: 2016-06-16 13:19 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1243644 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:19:46 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2015-07-06 08:24:20 UTC
Description of problem:
Metadata self-heal is not handling failures while heal properly. This is leading to crashes while accessing members that are NULL.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-07-06 11:24:59 UTC
COMMIT: http://review.gluster.org/11546 committed in master by Xavier Hernandez (xhernandez@datalab.es) 
------
commit 69c48f592afad1eb15a1f355226bda077c2ec1ef
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Mon Jul 6 12:22:20 2015 +0530

    cluster/ec: Remove failed subvols from source/sink computation
    
    Change-Id: Ib0de34c86ee25de361ec821d4015296c514742e0
    BUG: 1240210
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/11546
    Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 2 Nagaprasad Sathyanarayana 2015-10-25 14:55:02 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 3 Niels de Vos 2016-06-16 13:19:46 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.