Bug 1243644 - Metadata self-heal is not handling failures while heal properly
Summary: Metadata self-heal is not handling failures while heal properly
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: 3.7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On: 1240210
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-16 02:43 UTC by Pranith Kumar K
Modified: 2015-07-30 09:47 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1240210
Environment:
Last Closed: 2015-07-30 09:47:51 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2015-07-16 02:43:44 UTC
+++ This bug was initially created as a clone of Bug #1240210 +++

Description of problem:
Metadata self-heal is not handling failures while heal properly. This is leading to crashes while accessing members that are NULL.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2015-07-06 07:24:59 EDT ---

COMMIT: http://review.gluster.org/11546 committed in master by Xavier Hernandez (xhernandez@datalab.es) 
------
commit 69c48f592afad1eb15a1f355226bda077c2ec1ef
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Mon Jul 6 12:22:20 2015 +0530

    cluster/ec: Remove failed subvols from source/sink computation
    
    Change-Id: Ib0de34c86ee25de361ec821d4015296c514742e0
    BUG: 1240210
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/11546
    Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 1 Anand Avati 2015-07-16 03:26:35 UTC
REVIEW: http://review.gluster.org/11681 (cluster/ec: Remove failed subvols from source/sink computation) posted (#1) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Anand Avati 2015-07-21 11:55:14 UTC
REVIEW: http://review.gluster.org/11681 (cluster/ec: Remove failed subvols from source/sink computation) posted (#2) for review on release-3.7 by Xavier Hernandez (xhernandez@datalab.es)

Comment 3 Anand Avati 2015-07-21 21:40:36 UTC
COMMIT: http://review.gluster.org/11681 committed in release-3.7 by Xavier Hernandez (xhernandez@datalab.es) 
------
commit 75c20274002982bade23179b3680025c0bce7af4
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Mon Jul 6 12:22:20 2015 +0530

    cluster/ec: Remove failed subvols from source/sink computation
    
     >Change-Id: Ib0de34c86ee25de361ec821d4015296c514742e0
     >BUG: 1240210
     >Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
     >Reviewed-on: http://review.gluster.org/11546
     >Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>
     >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
     >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    
    BUG: 1243644
    Change-Id: I41817ca933bb1eecdb3e895a16753226b608814a
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/11681
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>

Comment 4 Kaushal 2015-07-30 09:47:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.