Bug 1240244 - Unable to examine file in metadata split-brain after setting `replica.split-brain-choice' attribute to a particular replica
Summary: Unable to examine file in metadata split-brain after setting `replica.split-b...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Anuradha
QA Contact:
URL:
Whiteboard:
Depends On: 1238398
Blocks: 1256909
TreeView+ depends on / blocked
 
Reported: 2015-07-06 10:31 UTC by Anuradha
Modified: 2016-09-20 02:01 UTC (History)
8 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1238398
: 1256909 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:20:35 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-07-06 10:42:11 UTC
REVIEW: http://review.gluster.org/11551 (cluster/afr : Examine data/metadata readable for read-subvol) posted (#1) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 2 Anand Avati 2015-07-07 12:40:21 UTC
REVIEW: http://review.gluster.org/11551 (cluster/afr : Examine data/metadata readable for read-subvol) posted (#2) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 3 Anand Avati 2015-07-07 15:45:14 UTC
REVIEW: http://review.gluster.org/11551 (cluster/afr : Examine data/metadata readable for read-subvol) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 4 Anand Avati 2015-07-07 16:17:52 UTC
REVIEW: http://review.gluster.org/11551 (cluster/afr : Examine data/metadata readable for read-subvol) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 5 Anand Avati 2015-08-03 11:47:24 UTC
REVIEW: http://review.gluster.org/11551 (cluster/afr : Examine data/metadata readable for read-subvol During lookup and discover, currently read_subvol is based only on data_readable. read_subvol should be decided based on both data_readable and metadata_readable.) posted (#5) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 6 Anand Avati 2015-08-11 11:55:33 UTC
REVIEW: http://review.gluster.org/11551 (cluster/afr : Examine data/metadata readable for read-subvol During lookup and discover, currently read_subvol is based only on data_readable. read_subvol should be decided based on both data_readable and metadata_readable.) posted (#7) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 7 Anand Avati 2015-08-25 17:33:02 UTC
COMMIT: http://review.gluster.org/11551 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 36349fa250ace6109002dfa41305d9dcd54ce0a9
Author: Anuradha Talur <atalur@redhat.com>
Date:   Mon Aug 3 17:09:13 2015 +0530

    cluster/afr : Examine data/metadata readable for read-subvol
    During lookup and discover, currently read_subvol is based
    only on data_readable. read_subvol should be decided based
    on both data_readable and metadata_readable.
    
    Credits to Ravishankar N for the logic of afr_first_up_child
    from http://review.gluster.org/10905/ .
    
    Change-Id: I98580b23c278172ee2902be08eeaafb6722e830c
    BUG: 1240244
    Signed-off-by: Anuradha Talur <atalur@redhat.com>
    Reviewed-on: http://review.gluster.org/11551
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 8 Nagaprasad Sathyanarayana 2015-10-25 14:49:37 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 9 Niels de Vos 2016-06-16 13:20:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.