This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1256909 - Unable to examine file in metadata split-brain after setting `replica.split-brain-choice' attribute to a particular replica
Unable to examine file in metadata split-brain after setting `replica.split-b...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.7.3
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On: 1238398 1240244
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 13:35 EDT by Pranith Kumar K
Modified: 2015-09-09 05:40 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1240244
Environment:
Last Closed: 2015-09-09 05:40:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2015-08-25 13:36:19 EDT
REVIEW: http://review.gluster.org/12011 (cluster/afr : Examine data/metadata readable for read-subvol During lookup and discover, currently read_subvol is based only on data_readable. read_subvol should be decided based on both data_readable and metadata_readable.) posted (#1) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Anand Avati 2015-08-28 03:13:19 EDT
COMMIT: http://review.gluster.org/12011 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 12649804d0c830bc17b685b904825e03b0e968cd
Author: Anuradha Talur <atalur@redhat.com>
Date:   Mon Aug 3 17:09:13 2015 +0530

    cluster/afr : Examine data/metadata readable for read-subvol
    During lookup and discover, currently read_subvol is based
    only on data_readable. read_subvol should be decided based
    on both data_readable and metadata_readable.
    
    Credits to Ravishankar N for the logic of afr_first_up_child
    from http://review.gluster.org/10905/ .
    
    > Change-Id: I98580b23c278172ee2902be08eeaafb6722e830c
    > BUG: 1240244
    > Signed-off-by: Anuradha Talur <atalur@redhat.com>
    > Reviewed-on: http://review.gluster.org/11551
    > Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    > Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    > (cherry picked from commit 36349fa250ace6109002dfa41305d9dcd54ce0a9)
    
    Change-Id: Ia068ef9deb97f7bc48ea0c56d5ab6851f8860118
    BUG: 1256909
    Signed-off-by: Anuradha Talur <atalur@redhat.com>
    Reviewed-on: http://review.gluster.org/12011
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 3 Kaushal 2015-09-09 05:40:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.