Bug 1240254 - quota+afr: quotad crash "afr_local_init (local=0x0, priv=0x7fddd0372220, op_errno=0x7fddce1434dc) at afr-common.c:4112"
Summary: quota+afr: quotad crash "afr_local_init (local=0x0, priv=0x7fddd0372220, op_e...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Vijaikumar Mallikarjuna
QA Contact:
URL:
Whiteboard:
Depends On: 1239317
Blocks: 1240906
TreeView+ depends on / blocked
 
Reported: 2015-07-06 11:13 UTC by Vijaikumar Mallikarjuna
Modified: 2016-06-16 13:20 UTC (History)
9 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1239317
: 1240906 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:20:35 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-07-06 11:16:07 UTC
REVIEW: http://review.gluster.org/11552 (quotad: create sock listener only after graph init is complete) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Anand Avati 2015-07-06 12:06:48 UTC
REVIEW: http://review.gluster.org/11552 (quotad: create sock listener only after graph init is complete) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Anand Avati 2015-07-07 12:58:31 UTC
REVIEW: http://review.gluster.org/11552 (quotad: create sock listener only after graph init is complete) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 4 Anand Avati 2015-07-08 05:45:03 UTC
REVIEW: http://review.gluster.org/11552 (quotad: create sock listener only after graph init is complete) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 5 Anand Avati 2015-07-09 12:33:41 UTC
COMMIT: http://review.gluster.org/11552 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 41266ec75d729c53ab748aa2ac1fa0d0515b97d6
Author: vmallika <vmallika@redhat.com>
Date:   Mon Jul 6 16:18:45 2015 +0530

    quotad: create sock listener only after graph init is complete
    
    If FOPs are received before completing graph initialization,
    FOP path can crash while accessing uninitialized variables
    
    This patch fixes issue by not creating listener until
    graph initialization is complete and hence not receiving
    FOP request
    
    Change-Id: I4771e376410843dff44bfe819329a4632523d266
    BUG: 1240254
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/11552
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 6 Nagaprasad Sathyanarayana 2015-10-25 14:42:47 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 7 Niels de Vos 2016-06-16 13:20:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.