Bug 1240360 - Live merge fails when deleting a snapshot
Summary: Live merge fails when deleting a snapshot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ovirt-3.6.0-rc3
: 3.6.0
Assignee: Adam Litke
QA Contact: Kevin Alon Goldblatt
URL:
Whiteboard:
Depends On:
Blocks: 1272077
TreeView+ depends on / blocked
 
Reported: 2015-07-06 16:40 UTC by Bimal Chollera
Modified: 2019-10-10 09:55 UTC (History)
13 users (show)

Fixed In Version: ovirt-engine-3.6.0.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1272077 (view as bug list)
Environment:
Last Closed: 2016-03-09 21:09:28 UTC
oVirt Team: Storage


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 44331 master MERGED Live Merge: Fix pre-extension calculation for chunked drives Never
oVirt gerrit 45058 ovirt-3.6 MERGED Live Merge: Fix pre-extension calculation for chunked drives Never

Description Bimal Chollera 2015-07-06 16:40:28 UTC
Description of problem:

Live Merge failed when deleting snapshot.

Version-Release number of selected component (if applicable):

rhevm-3.5.0-0.32.el6ev.noarch
vdsm-4.16.13.1-1.el7ev.x86_64
libvirt-1.2.8-16.el7_1.2.x86_64
qemu-kvm-rhev-2.1.2-23.el7_1.3.x86_64

How reproducible:

Not always.

Steps to Reproduce:

VM with multiple snapshots
Delete the snapshot

Actual results:

The live merge fails leaving the disk's image in a 'illegal state'.

Expected results:

Snapshot should be removed and live merge should complete without any failure.


Additional info:

Comment 9 Sandro Bonazzola 2015-10-15 09:51:19 UTC
Please clone to ZStream

Comment 11 Kevin Alon Goldblatt 2015-11-11 12:56:25 UTC
Tested with the following code:
---------------------------------------
vdsm-4.17.10.1-0.el7ev.noarch
rhevm-3.6.0.3-0.1.el6.noarch

Libvirt:
---------------------------------------
libvirt-client-1.2.17-13.el7.x86_64
libvirt-python-1.2.17-2.el7.x86_64
libvirt-daemon-driver-interface-1.2.17-13.el7.x86_64
libvirt-daemon-driver-storage-1.2.17-13.el7.x86_64
libvirt-daemon-1.2.17-13.el7.x86_64
libvirt-daemon-driver-nwfilter-1.2.17-13.el7.x86_64
libvirt-daemon-config-nwfilter-1.2.17-13.el7.x86_64
libvirt-daemon-driver-nodedev-1.2.17-13.el7.x86_64
libvirt-daemon-driver-secret-1.2.17-13.el7.x86_64
libvirt-daemon-driver-qemu-1.2.17-13.el7.x86_64
libvirt-daemon-kvm-1.2.17-13.el7.x86_64
libvirt-daemon-driver-network-1.2.17-13.el7.x86_64
libvirt-lock-sanlock-1.2.17-13.el7.x86_64

Qemu
----------------------------------------
ipxe-roms-qemu-20130517-7.gitc4bce43.el7.noarch
qemu-kvm-tools-rhev-2.3.0-31.el7.x86_64
qemu-kvm-common-rhev-2.3.0-31.el7.x86_64
libvirt-daemon-driver-qemu-1.2.17-13.el7.x86_64
qemu-img-rhev-2.3.0-31.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7.x86_64


Tested with the following scenario:
---------------------------------------
1. Created VM with 4 disks - 2 block prealloc and thin and 2 nfs prealloc and thin
2. Start VM
3. Create snapshots snap1, snap2, snap3, snap4, snap5
4. Deleted snap2 - successful Live Merge
5. Deleted snap4 - successful Live Merge
6. Deleted snap1 - successful Live Merge


Moving to Verified!

Comment 13 errata-xmlrpc 2016-03-09 21:09:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.