Bug 1272077 - [z-stream clone 3.5.6] Live merge fails when deleting a snapshot
[z-stream clone 3.5.6] Live merge fails when deleting a snapshot
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.0
Unspecified Unspecified
urgent Severity urgent
: ovirt-3.5.6
: 3.5.6
Assigned To: Adam Litke
Aharon Canan
storage
: ZStream
Depends On: 1240360
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 08:34 EDT by rhev-integ
Modified: 2016-02-10 13:49 EST (History)
16 users (show)

See Also:
Fixed In Version: v4.16.28
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1240360
Environment:
Last Closed: 2016-01-06 07:09:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44331 master MERGED Live Merge: Fix pre-extension calculation for chunked drives Never
oVirt gerrit 45058 ovirt-3.6 MERGED Live Merge: Fix pre-extension calculation for chunked drives Never
oVirt gerrit 47589 ovirt-3.5 MERGED Live Merge: Fix pre-extension calculation for chunked drives Never

  None (edit)
Comment 1 Aharon Canan 2015-11-05 11:35:36 EST
please approve below steps for verification (or suggest other steps)

1. Set VM with disk on Block domain
2. Install OS
3. Add new 5G thin provision disk (Block)
4. Take snapshot of the disk created on step 3
5. Write 4G file on the new disk
6. Remove the snapshot (live merge)
Comment 2 Allon Mureinik 2015-11-12 08:25:58 EST
Sorry for the late reply, had a glitch in communication here.
The steps in comment 1 are sufficient, thanks Aharon!
Comment 3 Adam Litke 2015-11-13 14:04:34 EST
Aharon, it's tricky to trigger the bad behavior since you need specific combinations of qcow data allocated to the base and top volumes.  Please follow these steps for verification:

1. Install a VM with a single system disk
2. Add a new 5G thinly provisioned block disk
3. Boot the VM and write a 2G file to the disk created in step 2.
4. Take a snapshot.
5. Write a different 2G file to the disk from step 2.
6. Live merge.
Comment 4 Aharon Canan 2015-11-17 12:13:07 EST
(In reply to Adam Litke from comment #3)
> Aharon, it's tricky to trigger the bad behavior since you need specific
> combinations of qcow data allocated to the base and top volumes.  Please
> follow these steps for verification:
> 
> 1. Install a VM with a single system disk
> 2. Add a new 5G thinly provisioned block disk
> 3. Boot the VM and write a 2G file to the disk created in step 2.
> 4. Take a snapshot.
> 5. Write a different 2G file to the disk from step 2.
> 6. Live merge.

Verified using vt18.2
Comment 5 Allon Mureinik 2016-01-06 07:09:39 EST
RHEV 3.5.6 has been release, updating status accordingly.

Note You need to log in before you can comment on or make changes to this bug.